The code execution cannot proceed because python 39.dll was not found

Tried installing the new anki update (23.12.1 QT6) for Windows 11 version. Keep getting the error message:
anki.exe system error - the code execution cannot proceed because python 39.dll was not found. Reinstalling the program may fix this problem.
Does anyone have a solution to fixing this?

1 Like

First things first: did you try reinstalling as suggested?

1 Like

My problem is there is no uninstall.exe in any of my anki files. ive checked both my drives and find the anki folder (incl %appdata%) but I cannot find uninstall.
As well as this, trying to uninstall from windows settings doesn’t let me and just deleting the files didn’t work either.
Not sure what to do

Reinstalling automatically uninstalls the existing install.

But you can also go to Settings (shortcut: Windows-key + i) and then go to Apps / Installed apps, then click on the … at the right-hand side for the Anki entry in the listing, and then select Uninstall.

Doing the uninstalling of settings comes with this error:
Windows cannot find D:/anki/uninstall.exe.
Trying to download the new version to ‘reinstall’ it comes up with this (after it telling me I have an older version that needs to be uninstalled):
Error opening file for writing: D:/anki/mpv.exe

Not sure what to do

Open the Task Manager with Ctrl+Shift+Esc.

Find the mpv app and terminate it. After that you will be able to install.

  • (Right-click on mpv and select End Task from the pop-up menu).

Rebooting the computer is another way to terminate the mpv app (and all other tasks).

Probably Anki crashed at some point and left an orphaned mpv task running.

That worked thank you.

1 Like

it is unresolved!
Doesn’t seem to be opening anki so not sure whats wrong

Did the install complete without errors?

What error do you get when running Anki?

i get no error, it just simply doesn’t open. Im looking on taskbar to see if it opens but it doesn’t. I now have two shortcuts on my homescreen and when looking at file location it goes into the anki file so not sure what is wrong

Older versions of Anki (until a few versions ago) required Administrator permission and installed for every Windows user to use. The latest versions install locally just for you, and should be installed without running as Administrator.

So maybe that is why you have two shortcuts on your Desktop. Make sure you are running the right one (the one installed in AppData/Local/ ).

going into appdata/local, there isnt an anki.exe or an application to run. the only anki application i can find is the one in d:/anki
not sure what to do

It’s actually in AppData\Local\Programs\Anki\anki.exe

The Desktop shortcut should point to that.

When you ran the install, did you do it as Administrator? If so, do it again but not as Administrator.

okay finally sorted it all out, i had to just download it into appdata rather than d:/ anki
did not expect the new anki to look like this
thanks for all the help!

When you run the install as yourself (not as Administrator) it automatically installs into AppData\Local\Programs\Anki\anki.exe

Glad to hear it’s working now.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.