Text to Speech issue on MacOS Ventura

I’ve been using a tts tag on my cards for some time without issues with the following tag:

{{tts en_US voices=Microsoft_Mark speed=1.5:Front}}

Recently I purchased a new MacBook Pro with the M2 Pro chip and when I attempted to use Anki the first time the card text was read, but the speech was garbled, very fast and almost incomprehensible. Changing the voice to various voices in the supported list from tts-list resulted in no change to the voice or result.

I installed it on a my work machine (running Ventura on an Intel chip) and got the same result. I tried versions 2.1.54, 2.1.56 and 2.1.49 with the same results.

I didn’t see any topics in the forum - hard to believe I’m the only one with this issue. Is this a known issue and/or is there a work around? It’s unusable in the current state on my machines.

I downloaded the source code and took a look at how Anki uses TTS - it looks like it uses the “say” command. Using the command line, it looks like my TTS is working, but from Anki it’s 100% garbled.

It looks like the issue is how it selects a voice if the desired voice is not present. Since the Microsoft_Mark voice is not there, it’s grabbing some bizarre (I’m guessing one of the specialty voices) whereas before it grabbed something slightly more sane. If I change the voice to “Apple_Samantha” it works correctly.

I see now you can specify different voices, depending on OS, so I’ll do that - I guess I just got lucky it was grabbing a sane voice before. Too bad you can’t specify speeds by OS - some voices don’t work at higher speaking tones.

Providing separate speed multipliers for each voice is not a bad idea, as the different platforms can treat the multiplier differently.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.