Anki TTS speed on Mobile

So I use Anki tts for the AnKing deck on Mac at 3.0x and it works fine. Then I switch to the Anki app on iPhone and the audio just goes insanely fast. Is there a update or an option to fix this? Thanks.


I seem to recall some changes to fix this in the past - what AnkiMobile and computer version are you using?

Hey! Thanks for the quick reply.

I’m on 2.0.67(2.00671) for mobile and 2.1.35 for Mac.

. @dae

I suspect it’s similar to TTS and Audio Speed on Mac and iOS - the two platforms use different implementations, and the multiplier in iOS does not appear to behave in the same way as the “words per minute” setting the computer version uses. Perhaps if you used 2x you’d get more similar behaviour across the two platforms?

@dae Hmm, is there a way to set 2 different div classes/speeds? (e.g. 1x on iOS and 3x on Mac)

The speed on the two platforms is supposed to be roughly equivalent when left at the default settings. If you find you need to set your Mac to 3x speed to get it to play at the same speed as 1x on iOS, that seems like something is wrong. Please let me know the tts line you’re using, and I’ll try to reproduce the problem.

@dae {{tts en_US voices=Apple_Alex speed=3.0 :cloze:Text}}

What iOS version are you using? I’m wondering if Apple have changed the behaviour again in iOS 14.

I’ll dig into it more.

@dae I’m on iOS14.2.1

If you’d like to try a beta build which should improve this, please let me know.