Syncing network error Windows 11

When trying to download my collection to my new computer, it first says “Local collection has no cards. Download from AnkiWeb?” Proceeding with this results in the message “Downloading from AnkiWeb…” continuing on for ~30 min. making no progress before eventually throwing a network error:

"A network error occurred.

Error details: request or response body error: error reading a body from connection: end of file before message length reached"

Media sync log shows this indefinitely until the process is aborted:

This is on Anki version 2.1.49, but also tested with 2.1.54 Qt5, same result.

My old laptop (Windows 10) and my Android phone, both connected to the same network as my new laptop, can sync with no issues. I was able to successfully do a full download on them after deleting my local collection.

I’ve tried:

  • Restarting Anki
  • Checking database from the tools menu
  • Reinstalling Anki twice, first with version 2.1.54 Qt5, then going back to 2.1.49, restarting my computer in between each uninstall
  • Logging out and back in from my AnkiWeb account
  • Temporarily disabling Windows Defender Firewall
  • Turning Windows Defender off (at the time, I didn’t have any other antivirus installed)

I didn’t have any add-ons at the time of trying these fixes.

My partial workaround that kind of (?) works was to manually transfer my collection.anki2 file and folder via USB drive from my old laptop. After doing this, I’ve been able to successfully sync changes (upload and download) - it shows the standard sync dialogue box:


But after it finishes, the sync icon at the top right indicates that it’s still syncing, and opening the media sync log displays the same thing as the first pic.

Using mtr, apparently I do have a bit of packet loss for some of the servers (~1-3%). Would this be the cause of the perpetual “Added: ⁨0⁩↑ ⁨0⁩↓, Removed: ⁨0⁩↑ ⁨0⁩↓, Checked: ⁨1000⁩” logs? Is there anything else I can do as far as troubleshooting goes?

If another computer works fine on the same network, that seems to imply the issue is either some sort of filtering running on the machine, or an issue with the wifi card/driver. If you use a proxy/VPN, temporarily disabling it to see if it helps might be worth a try. If you have access to a different wifi network, it may be worth trying to sync on that, to see if it’s some sort of issue between the wifi card and your home router. Or you could try sync via a hotspot with your phone (but be careful of your phone’s data limit).


So I decided I would give it another shot on the same network before I tried it with a hotspot (I don’t have access to another wifi network) and for whatever reason it miraculously works now? As far as I’m aware, I didn’t change anything since my previous attempt, so I’m not really sure what happened there. I’d like to conclude it was just a temporary network issue, but that wouldn’t explain the fact that other devices worked fine… In any case, thanks for the suggestions!

1 Like