Sync error on Mac App

Have had anki for past couple of months but get the following error whenever I Sync.
“ A network error occurred.

Error details: ⁨error sending request for url (): error trying to connect: tcp connect error: Operation not permitted (os error 1)⁩”

  • I don’t have any firewalls
    -no Vpn
    -WiFi works fine
    -in system preferences, only requesting access to accessibility and it’s granted (in system preferences>security and permission)

You probably have a proxy setup for local addresses too.

1 Like

thanks for responding. I’m not sure what that means exactly. I went to the wifi settings page for proxies, and this is what it shows.

it says on the manual that anki honours system proxy… and has that thing with an asterisk that looks similar to the thing in the bottom of the screen shot (bypass box?). Im not sure what any of that means.

sorry for my ineptitude with this stuff

(manual: Anki needs to be able to make outbound HTTPS connections to sync. It must be able to connect to ankiweb.nt, sync.ankiweb.nt, sync2.ankiweb.nt, and so on. These domains may change over time, and the IP addresses they point to may also change, so we recommend you allow wildcard access to *ankiweb.nt to reduce the chance of the firewall rules needing to be updated in the future.)

EDIT: I tried adding * to bypass proxy setting for these domains, and it still doesn’t work

Sorry for double posting, but why exactly would this issue come up all of a sudden without any change in my computer/wifi/location/activity?

TBH, I have no idea. However, we don’t know yet if the problem is really a misconfigured proxy; maybe when the problem will be more clear, it will also be more clear why it suddenly fails.

Besides, could you post your system version, and Anki version — just to be sure I’m reading the appropriate proxy documentation :slight_smile: ?

I have the impression that you basically have no proxy configuration, so it could hardly be misconfigured. However, if it is misconfigured, according to this other thread where somebody had a similar problem, even when syncing, Anki needs to make local connections, not only outgoing ones. You may want to try to add localhost to that list of bypassed hosts. Alternatively, localhost is most likely to be a “simple hostname”, so checking that box might also do the trick.

Please see Syncing failed: Connection timed out errors when syncing - Frequently Asked Questions