Sync error after update to 24.04

I’m using AnkiMobile 24.04 and am now getting a sync error on the iPhone. The sync dialogue starts and closes, but the little wheel next to ‘Synchronize’ at the bottom right keeps spinning. After a little while a window pops up saying

'A network error occurred.

Error details: error sending request for url (): connection error: Socket is not connected (os error 57).’

This happens on any Wifi network and with mobile data.

AnkiWeb and the desktop app (on macOS) work fine.

Is this still happening?

AnkiWeb has had some intermittent server connection issues in the past few days, in some parts of the world. It’s possible that is causing this. It doesn’t seem like it could be a broader bug since that version of the app has been out for 2 months.

The other likely cause is antivirus/firewall/VPN on your device – which would include things like “private relay.”

Yes, it’s still happening - on my WiFi at home (doesn’t matter if “Private Wi-Fi Address” turned off or on), on mobile data, and on my university WiFi. I don’t use a VPN - just for the sake of it, I’ve also tried with NordVPN and I get the same error.

I’m not sure it has any consequences for the synchronization though. If I study a few cards on the desktop app, synchronize, and then synchronize the iOS app, the repetition count looks identical.

Any other reasons why I might be getting this error?

The fact that it’s happening for the device, regardless of what internet you’re using, suggests that it’s device-specific. Is “Private Wi-Fi Address” the same as the “private relay” settings in your phone? :person_shrugging:t4: I’ll defer to your expertise!

I have just enough experience with iPhones to know that there are all sorts of things they try to “help” you with whether you want it or not. I would look at what else has changed on your phone “recently” – going back to the 1st of the year, when the previous Anki update came out.

'Private Wi-Fi Address" is just a setting for Wi-Fi that assigns a unique MAC address for each Wi-Fi network that the iPhone connects to. There’s no private relay as far as I know.

But nothing has changed on my iPhone from the previous version of AnkiMobile that generated no error, and the update to 24.04 that I installed only recently - and that’s when the problem started. Not saying that this is the problem, but odds are it has something to do with AnkiMobile 24.04 and iOS 17.5.1.

1 Like

This is something I always miss, so just in case, are you using a private DNS? This one causes problems for me in various sites.

If not, just to confirm, can you downgrade to a previous version and check if this is still happening?

I mentioned “private relay” because it looks to be a relatively new iCloud feature, and it’s been mentioned recently by other iOS users as the source of similar errors.

Thank you for providing your iOS version information as well – that will help us match this up if there are any similar reports.

There’s generally no way to downgrade apps on iOS, as was suggested in the other post, so I’m glad to hear that syncing appears to be successful for you despite this error. Hopefully that continues, and this will only be a minor annoyance for the time being.

Anki 24.06.x has released for Desktop, so an iOS update should be released soon. That will probably be the next thing to try.

Just to confirm, I have “private relay” turned off.

1 Like

A couple of things to try:

  • if media syncing is disabled, does the error go away? If so, it’s likely related to some large file
  • increasing the network timeout in the preferences screen to 2 minutes may help
1 Like

The second suggestion (120 instead of 60 in Preferences > Syncing > Network timeout) did the trick, though I don’t know why. Thank you so much!

1 Like