Sound files won’t play on my new phone

This question has been asked before, but I haven’t seen a solution. I just bought an Oppo A96 (Android 11), downloaded AnkiDroid and synchronized my collection with Ankiweb. The .mp3 files appear on the cards and work with other apps (and AnkiWeb), but not AnkiDroid. Check Media didn’t help. Someone said it could be a problem with JavaScript, but I couldn’t understand the suggested fix.

My latest idea is that the problem is the AnkiDroid directory. The sound files are in Phone storage/AnkiDroid/, while AnkiDroid’s default directory is /storage/emulated/0/AnkiDroid. I’ve tried changing the default directory to match the one on the phone, but everything I try “isn’t a valid directory.” Oddly enough, the default directory on my old phone, where everything worked perfectly, was the supposedly incompatible /sdcard/AnkiDroid. I’m baffled.

The problem seems to have solved itself. The first synchronization with AnkiWeb seemed complete, but it apparently took several more for the sound files to download to my phone. Now they all seem to work.