Scalling problems on qt5 and qt6 with ANKI_WEBSCALE

When I run anki anki-2.1.51-linux-qt6 with
ANKI_WEBSCALE=0.9 ./anki text in viewer and preview are normal, I mean the size that I set in previous anki version in template but there are inconsistencies in interface with 120%:

interface seems to match

but reviewer and preview becomes ridiculously huge:

When I have 100% in preferences and keep ANKI_WEBSCALE=1.2 viewer keeps huge and interface is too small.

Version ⁨2.1.51 (cf78a555)⁩
Python 3.9.10 Qt 6.2.2 PyQt 6.2.2

Maybe the solution would be if ANKI_WEBSCALE would not affect font sized set in template.

The same is on Version ⁨2.1.51 (cf78a555)⁩
Python 3.9.10 Qt 5.15.2 PyQt 5.15.5
and it also doesn’t work properly.
Version ⁨2.1.52 (a989e508)⁩
Python 3.9.10 Qt 5.15.2 PyQt 5.15.5

So, it doesn’t work on QT5 and QT6 with any Anki version.

My system uses
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Graphics Platform: X11
Graphics Processor: NVA8

I wonder if the problem disappears when system QT gets upgraded.

I report it because I suppose that you created ANKI_WEBSCALE option as a native alternative independent from add-ons.

I don’t want to annoy you Damien but font size option provided by add-on was really the solution that has worked for years perfectly and still works. That is a surprise to me but Set Font Size seems to work on Version ⁨2.1.51 (cf78a555)⁩
Python 3.9.10 Qt 5.15.2 PyQt 5.15.5
and on
Version ⁨2.1.52 (a989e508)⁩
Python 3.9.10 Qt 5.15.2 PyQt 5.15.5
and everything scales properly.

WEBSCALE applies the same scaling to all areas of the app, including your card templates. If you designed them to go with a smaller size, then they’ll need adjusting.

The WEBSCALE workaround is not required on most machines from what I can tell, and perhaps depends on your system DPI setting. An option to set a font may come at one point, but I do not have time at the moment, and it looks like that add-on will get an update anyway.