"rid" search filter occasionally doesn't work

In the Browse window there is a search filter rid that queries all reviews within a given interval in Unix timestamps. Example: rid:1630321200000:1630407600000.

This rid filter is used by the Review Heatmap addon; it opens a Browse window with an autofilled search when you click on a certain day’s box (see relevant code snippet here). Strangely, this filter doesn’t seem to be documented anywhere in Anki’s manual.

Occasionally, rid fails and returns 0 results. This happens even when disabling all addons and on latest Anki (2.1.47). I’ve tried to reproduce it but the problem seems to happen randomly, and restarting Anki only fixes it about 25% of the time.

The rid filter is actually a custom filter created by the add-on.


Wow, i could’ve sworn it worked at one point when I turned off all the addons.

Seems like the heatmap addon is just faulty in newer versions of Anki then.

Thanks for the info

@redtree5 If you have time, it would be great if you could file a bug report on Review Heatmap’s bug tracker. I would especially appreciate it as this is the first time I’m seeing this issue and so it would be very helpful to understand what might be factoring into the problem. The bug report template takes care of guiding you through a number of debugging steps which should make it easier to narrow things down.

Either way, appreciate your bringing this to my attention!

1 Like