Review Heatmap [Official Support Thread]

Hi Essadon, thanks for the feedback! I’m planning on addressing this limitation with v1.1.0. You can track progress on that here: Add support for new congratulations screen · Issue #152 · glutanimate/review-heatmap · GitHub

On an unrelated note, judging by your debug info you’re likely using an old version of the add-on. To automatically receive updates such as the one adding support for the finished deck screen, please consider updating to the AnkiWeb version: Review Heatmap - AnkiWeb

Heatmaps aren’t appearing, just broken image icons.

Cannot delete add-on - error message:
Unable to update or delete add-on. Please start Anki while holding down the shift key to temporarily disable add-ons, then try again. Debug info: <U+2068>[Errno 13] Permission denied: ''<U+2069>

Cannot disable - error message:


An error occurred. Please use Tools > Check Database to see if that fixes the problem.

If problems persist, please report the problem on our [support site]( Please copy and paste the information below into your report.

Anki 2.1.54 (b6a7760c) Python 3.9.7 Qt 6.3.1 PyQt 6.3.1

Platform: Mac 12.5

Flags: frz=True ao=False sv=2

Add-ons, last update check: 2022-08-02 11:37:16

Caught exception:

Traceback (most recent call last):

File "aqt.addons", line 878, in onToggleEnabled

File "aqt.addons", line 322, in toggleEnabled

File "aqt.addons", line 282, in write_addon_meta

File "aqt.addons", line 303, in writeAddonMeta

PermissionError: [Errno 13] Permission denied: '/Users/ian/Library/Application Support/Anki2/addons21/review_heatmap/meta.json'

Thanks for the report! Not sure why deleting or disabling the add-on aren’t working, but it could be an issue with file permissions and/or your system drive. I would suggest manually navigating to /Users/ian/Library/Application Support/Anki2/addons21 via Finder (to go directly to a specific folder see this Apple support guide. Alternatively you could also head to Tools → Add-ons within Anki, make sure no add-on in the add-on list is selected, and then click the View Files button.

Either way, once you are in the addons21 folder, make sure to close Anki, and then please find the folder called review_heatmap and delete it. With that, Review Heatmap should be manually uninstalled.

Next, please re-download the add-on from the AnkiWeb listing (you currently have an older version of the add-on installed that doesn’t auto-update). If everything went well, after restarting Anki you should see the heatmap again.

That worked! Thanks for the quick response!

1 Like

Hello, good afternoon.

When I double-click on the Anki icon, an error message pops up. I tried searching for the error on Google, but couldn’t find anything useful. I have copied and pasted the error message to the bottom of my post. I followed the steps on the ‘When problems occur’ page’ and the problem is the add-on “Review Heatmap”. I really would use it, but I need stay with Anki 2.1.22 version because of my others add-nos. What should I do?

P.S.: I am your supporter on Patreon.

Best regards,

Debug Info:

Anki 2.1.22 (0ecc189a) Python 3.8.0 Qt 5.14.1 PyQt 5.14.1

Platform: Windows 10

Flags: frz=True ao=True sv=2

Add-ons, last update check: 2022-08-13 17:27:31

Caught exception:

Traceback (most recent call last):

File “aqt\”, line 76, in handler

File “aqt\”, line 158, in setupProfileAfterWebviewsLoaded

File “aqt\”, line 195, in setupProfile

File “aqt\”, line 370, in loadProfile

File “aqt\”, line 1275, in call

File “C:\Users\Rodrigo\AppData\Roaming\Anki2\addons21\1771074083\”, line 74, in initializeHotkey

hotkey = config[“profile”][“hotkeys”][“toggle”]

KeyError: ‘toggle’

Hey cap.rocky,

Hmm, that’s a strange one. It looks like the add-on hotkey config got corrupted somehow, but no need to worry, we should be able to fix this with a quick manual intervention. Could you do the following for me, please?

  1. With Anki’s main screen open, please press Ctrl + Shift + : to open Anki’s debug console

  2. Please copy and paste the following commands into the debug console (the entry area at the top):

    from aqt import mw["heatmap"]["hotkeys"]["toggle"] = "Ctrl+R"
  3. Hit Ctrl + Return to run the commands. This will restore the invalid hotkey config.

  4. Close the debug console and return to Anki

After restarting Anki everything should hopefully go back to normal and the error message should no longer appear.

If it the error persists, please do let me know and we’ll troubleshoot from there.

Hope that helps for now :slight_smile: , and thanks a lot for your support, really appreciate it! :man_bowing:


I would like to Report a bug, I am unable to check previously reviewed cards.
Only those that are due are able to being shown on the browser after clicking on the review heat map.

Any help you can provide, would be much appreciated


I have made only your modification today at my Anki. So, this happened with some “Cloze Overlapper” cards:

And this is a “Cloze” one:

Could you help me, please?

@Cap.Rocky: Hmm, not sure what’s going on there. Since this is about CO, rather than Review Heatmap, would you mind sending me a DM or shooting me an email via That should make it easier to troubleshoot

@PedroSilva could you send me your Anki debug info? To copy it to your clipboard, please had to Help → About from Anki’s main screen (or Anki → About on macOS), and then click “Copy debug info”. Thanks!

1 Like

Hello, thank you for making this add-on, it is very useful and nice to visualise my progress!

One thing that I would like to request is the highlight box for the current day to be coloured white when Anki is in dark mode, because it is often difficult to find square representing the current day (please see the image below):

I hope this change is easy to implement, thanks in advance!

Thanks for the feedback! I agree that it’s harder to see than it should be. Will take this into consideration for the next major release :slight_smile:

1 Like

Hey glutanimate! Thanks a lot for your add-on. I’m not sure if it’s still OK to post it here, since I’m using a slightly older version of Anki – 2.1.43.

I’ve downloaded the add-on from anki-web and it should have supported the version I’m using out of the box, though it fails to load unfortunately.

I’ve tested several versions of Anki, and saw that at or after 2.1.44 the add-on is fixed (?). Is this possibly an Anki change or is Anki-web not downloading the right version.

I can’t update my Anki version because it breaks some decks I have (tested multiple versions of Anki-- 2.1.43 is the sweet spot atm).

I don’t know enough Python to troubleshoot either, sorry :frowning:

Thank you!

Problem description
Please describe the issue concisely in here. In case of an error: Walk us through the steps you took to get there. What happened? What did you expect to happen?

Add-on simply fails to load.

Please replace the space inside the brackets with an x if the following items apply:

[ x ] I’ve restarted Anki to see if it helps
[ x ] I’ve verified that I use the latest version of the add-on by redownloading it from AnkiWeb
I’ve verified that I use the latest version of Anki by checking at (anki-web link)
[ x ] I’ve tried to disable other add-ons to see if there are any interactions present
[ x ] My issue disappears when I hold shift while starting Anki.
[ x ] I’ve checked if anyone else reported this problem before by looking through the issue reports. I also checked to see if there is a section about known issues in the add-on description, documentation, or README.

Information about your Anki set-up
Version ⁨2.1.43 (0fbae6bc)⁩
Python 3.8.6 Qt 5.14.2 PyQt 5.14.2

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you've discovered the add-on that is causing the problem, please report the issue on the add-on support site.
Debug info:
Anki 2.1.43 (0fbae6bc) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Mac 10.16
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2022-11-19 22:24:48
Add-ons possibly involved: <U+2068>Review Heatmap<U+2069>

Caught exception:
Traceback (most recent call last):
  File "aqt/", line 53, in handler
  File "aqt/", line 142, in on_window_init
  File "aqt/", line 231, in setupProfile
  File "aqt/", line 413, in loadProfile
  File "aqt/", line 2188, in __call__
  File "/Users/user/Library/Application Support/Anki2/addons21/1771074083/", line 74, in initializeHotkey
    hotkey = config["profile"]["hotkeys"]["toggle"]
KeyError: 'toggle'

@moogul thanks for the report! Looks like the add-on config is in an undefined state, which might have happened when moving between Anki versions / different versions of the add-on. To fix this, please draw up Anki’s debug console (with Anki’s main window open, hit Cmd+Shift+; – if that doesn’t work, please see Anki’s manual for alternate bindings). Then please enter the following command and run it with Cmd+Enter:

from aqt import mw

del mw.col.conf["heatmap"]

This will delete Review Heatmap’s current settings, which will prompt the add-on to restore its defaults once you restart Anki. Hopefully that should get rid of the startup error.

1 Like

Thanks a lot! That fixed the issue! The error message no longer appears and the Review Heatmap seems to be working as normal.

(For others reading – CMD+ Enter is the right keypress to run the debug console on Mac.)

1 Like

morning, i’d like to suggest you viewing heatmap on finished decks too

Hi, thanks for the nice add-on!

Just wanted to report a bug.

The heatmap graph doesn’t show up (broken image icons) with the version: Anki for macOS 10.14.4+ (Intel, 2.1.61 Qt6).
And it throws an AttributeError: ‘QDateTime’ object has no attribute ‘setTime_t’.

With the following setup the add-on works perfectly:
Anki 2.1.61 (0c1eaf4c) Python 3.9.15 Qt 5.14.2 PyQt 5.14.1
Platform: macOS-13.3.1-x86_64-i386-64bit

Hey, thanks for the report. It sounds like you’re using an older version of the add-on. If you install the version you currently have installed (under Tools → Add-ons), and then reinstall the one from AnkiWeb, it should work fine again on 2.1.61.

Hi, you’re right! Now it works also on 2.1.61 QT6 :slight_smile: Thanks!

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools>Add-ons menu item to disable some add-ons and restart Anki, repeat until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue on the add-ons section of our support site.
Debug info:
Anki 2.1.62 (77dd1dc1) Python 3.9.15 Qt 6.5.0 PyQt 6.5.0
Platform: macOS-13.3.1-arm64-arm-64bit
Flags: frz=True ao=True sv=3
Add-ons, last update check: 2023-05-04 15:50:14
Add-ons possibly involved: ⁨Review Heatmap⁩

Caught exception:
Traceback (most recent call last):
File “/Users/raahul/Library/Application Support/Anki2/addons21/review_heatmap/gui/”, line 217, in
options_action.triggered.connect(lambda _: invokeOptionsDialog())
File “/Users/raahul/Library/Application Support/Anki2/addons21/review_heatmap/gui/”, line 209, in invokeOptionsDialog
dialog = RevHmOptions(config, mw, parent=parent)
File “/Users/raahul/Library/Application Support/Anki2/addons21/review_heatmap/gui/”, line 107, in init
super(RevHmOptions, self).init(
File “/Users/raahul/Library/Application Support/Anki2/addons21/review_heatmap/libaddon/gui/”, line 81, in init
super(OptionsDialog, self).init(
File “/Users/raahul/Library/Application Support/Anki2/addons21/review_heatmap/libaddon/gui/basic/”, line 154, in init
File “/Users/raahul/Library/Application Support/Anki2/addons21/review_heatmap/libaddon/gui/basic/”, line 162, in setData
self.interface.set(widget_name, key, value)
File “/Users/raahul/Library/Application Support/Anki2/addons21/review_heatmap/libaddon/gui/basic/”, line 270, in set
return setter(widget, data)
File “/Users/raahul/Library/Application Support/Anki2/addons21/review_heatmap/libaddon/gui/basic/”, line 354, in setValue
self._setDateTime(widget, data)
File “/Users/raahul/Library/Application Support/Anki2/addons21/review_heatmap/libaddon/gui/basic/”, line 800, in _setDateTime
return qdatetimeedit.setDateTime(self._createDateTimeFromUnix(curtime))
File “/Users/raahul/Library/Application Support/Anki2/addons21/review_heatmap/libaddon/gui/basic/”, line 793, in _createDateTimeFromUnix
AttributeError: ‘QDateTime’ object has no attribute ‘setTime_t’