Anki Forums

RAM usage goes up with each review, leading to slowdown

Hi all,

I’ve noticed a strange behavior with Anki in the past few weeks. Every time I complete a review Anki’s RAM usage goes up by a few megabytes. This piles up over time, meaning that when I start Anki it’s RAM usage is around 500 MB, but after a couple hundred reviews the RAM usage goes up to several gigabytes. In terms of my own experience, this means after several hundred reviews Anki slows down considerably, especially when opening up the card editing window or the browser.

If I restart Anki, the RAM usage goes back down to around 500 MB and Anki is snappy again, but RAM usage continues to pile up with every review I do.

Any ideas how to fix this? It’s a little frustrating seeing Anki gradually slow down over the course of my reviews. I assume this is a bug but maybe it’s something I’m doing wrong. I didn’t notice this problem before a few weeks ago, but I can’t think of anything that might have set off this behavior.

I’m using Anki version ⁨2.1.37 on Windows. I have around 90,000 cards total, with around 50,000 notes. The add-ons I have installed are AnkiConnect, Batch Editing, Japanese Pronunciation Pitch Accent, Japanese Support, Right Hand Answer Shortcuts, and The KING of Button Add-ons.

Thanks for your help!

1 Like

Might be related to your problem:

Interesting, I just did a quick test and I can also reproduce the behavior you reported not just in the add card window but in the review window as well. Moving the mouse around in the review screen increases RAM usage slightly over time just as you described. In addition, resizing the window increases RAM usage significantly. RAM usage then falls but not to its original level.

To describe in more detail, I started with Anki running 725.7 mb of RAM, and then resized the window. During resizing, RAM usage peaked at around 925 mb. Anki has now been sitting for a minute without me using it and RAM usage is at 890.5 mb.

In addition, the issue with reviews persists. Answering reviews, even without moving the mouse at all (ie, just using the keyobard) increases RAM usage over time. To put some numbers to it:
954.0 - before starting reviews
957.7 - after 1st review
963.0 - after 2nd review
971.5 - after 3rd review

And so on.

Thanks for your comment!

1 Like

Yea, I guess the problem occurs everywhere where Anki uses a webview to display content, e.g. the main window, deck overview, add/edit card, review, so basically most of the UI.
Do you have hardware acceleration enabled? Try disabling it if that is the case.

I do have hardware acceleration enabled, but just like what happened to you I can’t disable it. If I un-check the box for hardware acceleration upon Anki restart I get this message:

image

And Anki quits out. The next time I start up Anki, Anki successfully boots up… but with hardware acceleration enabled. So unfortunately I can’t test whether turning hardware acceleration would help at all.

That’s a bummer. I get the exact same error. What’s even weirder, the disabling works for me sometimes (seemingly random). Like if I uncheck and restart 10 times, I get the error (and resetting of the checkbox) 9 times, before it eventually succeeds. Although with the next restart, it will then be gone again.
But that magical one time where it randomly succesfully disables hardware acceleration, all the RAM problems are gone. :thinking:

Edit: Maybe it is a general problem on Windows, that users cannot disable hardware acceleration?
Maybe any other Windows user can confirm if it works for him or her?
At least the memory problem seems to occur for other Windows users too:

That is so bizarre. Any hope of this issue getting fixed you think? Hopefully someone else can chime in with help too.

I am not involved in the development. In the first thread I linked @dae said that the memory issue seems like a bug in Qt, so currently not directly fixable. But if the Hardware acceleration checkbox would work again, we could alleviate the problem in the meantime.

Got it. Thanks for helping out. I hope this gets sorted out soon! In the meantime I’ll just keep restarting Anki whenever RAM usage gets high enough to cause a noticeable slowdown. At least doing that Anki will be usable until a more permanent fix is made.

It may be worth trying the ‘angle’ driver:

The moving-the-mouse-uses-RAM issue seems to exist regardless of acceleration setting, but maybe it will help with the reviewing issues you’re getting.

3 Likes

Thanks a ton! The problem seems completely gone for me when using the angle driver.

Wow, thanks so much! This solved my review issues.

For me the moving-the-mouse issue still persists, but resizing the window and review issues seem totally solved by switching to the angle driver, at least as far as I can tell. Thank you! This is a big relief.