Anki causing high RAM usage (v2.1.41)

Good day. I have been using Anki with 5 addons for a few years now, and I am now getting RAM usage that is ramping up with how long I use the app and go through cards. Not really doing many cards (today whilst troubleshooting, I have done ~400 cards), but the RAM usage ramps up to ~2500mb and causes the card switching to lag/hesitate.

I thought it might have been a recent version issue, so I uninstalled and reinstalled an older version several times (all the way back to 2.1.35) and that didn’t solve the issue, it continued to ramp up RAM usage whilst using Anki.

I then thought it was an addon issue, so I played with uninstalling addons one by one to see which one was causing the issue and recording the RAM usage results. The same issue manifested with ZERO addons, where the RAM was continuously ramping up to around 1800mb and causing transition lag between cards. I am not sure where to go from here, but a solution or help would be lovely! Here is a screenshot of the RAM without addons and with going through ~50 cards:

Please note: Exiting and restarting Anki would reset the RAM usage to approximately 550mb, but then ramp up to as high as mentioned above. If given enough time, it would continue to ramp up. As I have been typing this, I have allowed Anki to run on idle without any addons, and it’s sitting around 600mb RAM usage. Please advise.

PS: Doubt it’s a computer issue as I am working on a new Alienware that’s about a week old and the issue was becoming an issue on my HP.

PSS: When I was uninstalling addons, it seemed to have sorted itself out when I got down to 2/5 addons, leading me to think that addon #3 was the culprit, I installed addons 4 and 5, but then the issue persists and also persisted through uninstalling all the addons. A weird bit to note.

1 Like

Sounds more like a plugin causing a possible memory leak on your specific system/environment.

Just for fun I ran 2.1.41 with sparsely populated plugins on my Mac system, switched profiles and did normal learning and sync for 20 minutes. The RSS grew from 134 to 157Mb. I need to keep it around a little bit longer. It looks like it grows memory or then allocates more in a cache or something similar – what could you do with all the added frameworks and plugins… Then again after all these years I’m used to quit apps when not used as I don’t trust the implementation and memory consumption.

Thank you for the response. However, I am not too sure how to go about troubleshooting this suggestion.

Forgive me, what is RSS?

I quit them when not in use also. However, in medical school I usually use Anki all day. Being that, I haven’t had this bad of an issue in the past.

Only way to isolate this is to disable all plugins and enable one at a time, or a group to see if a plugin caused the issue, also if it’s related to the specific Anki version that was added in. I assume you have not upgraded your Windows environment.

I assume you’re talking about Window’s plugins?

I received this laptop new on Friday, 3/5/21 and booted it up then too. There are no pending Windows updates. Here is my Windows version information:image

Please note, this was becoming an issue on my HP laptop that I was using up until Friday, but not as severely. However, I am not sure of the Anki version on there or Windows version on there. I can check that out later tonight if it will be helpful.

Yes, Anki plugins. Check your environments to see what the difference is, that’s always a start when diagnosing system/app issues.

Thank you. However, in the OP, I stated that I uninstalled all addons/plugins on Anki, and the issue persists.

I believe I have been experiencing this issue since I first used Anki (Windows). For half a year at least. I regularly need to restart Anki to get the memory usage down. It is quite crippling…
@prollo did a great bug report during the 2.1.36 beta phase:

Dae said it seems like a bug on Qt’s side, not Anki’s. It doesn’t seem to have been resolved though.

1 Like

I also have the same issue on Windows.

1 Like

Thank you for the response. I found that thread with a Google search, but I don’t think that is quite the same, and I am not adding cards/resizing the screen. I am running a 4k screen though, so might exponentially perpetuate the issue.

Qt’s side?

Edit 1: insert foot in mouth it’s the same thing. I just messed with the screen width and it shot up immediately and did not return. Any idea how to resolve this? Here’s a screenshot:

Edit 2: I took what @kleinerpirat said about graphics acceleration into consideration and changed the video driver to ANGLE, and it has seemed to fix the issue (after messing with the width, it shot up, but returned to normal). The issue seems to be with the OpenGL video driver. I will test this further tomorrow and will report back. Hopefully, this is a fix!

1 Like

Previous thread: RAM usage goes up with each review, leading to slowdown

1 Like

Dae, thank you for the link. For some reason, that didn’t show up when I was searching for some help. However, I was able to come to the same conclusion that changing the graphics driver to ANGLE, instead of OpenGL solved this problem. Thank you.

After running additional tests today and yesterday, the issue hasn’t resurfaced.


made an account on this forum just to thank you. this problem’s been bugging me for some time and made it so difficult to make cards. the RAM usage is still relatively high but much much lower than what it was before changing drivers, allowing my anki to run smoothly as if it just opened up

once again, thank you!