Anki Forums

Option+I shortcut conflicts with language input

Hi there,

I want to report a bug with 2.1.49 and Turkish Q - Legacy keyboard

On a mac, option + i key is used to select a letter of the Turkish alphabet (undotted i). In the new Anki version of Anki, however, it instead brings up the card information.

Is there a workaround for this or will I need to downgrade to an older version of Anki? As a vowel, this letter comes up all the time and hence my Turkish cards are not really reviewable at present.

Look forward to hearing from you,

Best wishes,

John

3 Likes

The option key together with the “i” is normally used on a Mac to insert the ^-accent.

For some reason someone (likely a certain Evandro) thought it was a good idea to replace this with a call to self.on_previous_card_info in review mode. I guess that is nice for Evandro and perhaps some other Anki users, but I would really prefer to enter accents. My fingers are programmed to use the option key for all kinds of accents.

Can I disable this anti-feature? Going back to the previous version of Anki I had installed seems not possible.

I’m very sad that I can no longer type the correct answers in my reviews and the dialog that pops up all the time when I try to enter a ^ might become slightly annoying over time :frowning:

I have this problem too. I just updated the Anki version today, and now I can no longer type in French.
Is there a way to change the key bindings? I looked thru the menu, but I can’t find anything. I’d like to bind that report to some other key instead of option-i.

The conflict was an oversight on my part, not Evandro’s. I’ll adjust the shortcut in the next update so it no longer conflicts.

2 Likes

Ah, I see it’s not just Turkish that’s affected. Thanks Damien for rectifying it with the next update.

J

1 Like