Open Backup not fixing syncing issue

Hello! I am getting the below message when I try to sync Anki on my computer. Anki is working fine on the app on my phone. I followed the instructions and opened a back up from a few weeks prior, but after the back up is synced, it brings up this same message and turns into a cycle. I tried all the tricks on the “when problems occur page” without avail (restarting anki, check add ons, etc). Thank you so much for your help.

Anki was unable to open your collection file. If problems persist after restarting your computer, please use the Open Backup button in the profile manager.

Debug info:
Traceback (most recent call last):
File “aqt/”, line 325, in loadCollection
File “aqt/”, line 354, in _loadCollection
File “aqt/”, line 468, in moveToState
File “aqt/”, line 474, in _deckBrowserState
File “aqt/”, line 27, in show
File “aqt/”, line 86, in _renderPage
File “anki/”, line 268, in deckDueTree
File “anki/”, line 245, in deckDueList
File “anki/”, line 439, in _deckNewLimitSingle
File “anki/”, line 340, in confForDid
File “anki/”, line 347, in getConf
KeyError: ‘1610292245891’

One of the things it suggests you try is the latest Anki version. If you update to the latest version, do you still get an error after running Tools>Check Database? If so, what does it say?

Thank you for the response! When I click Check Data base, it processes for a moment, then a message at the bottom left says “database rebuilt and optimized”. My anki version is 2.1.5.

2.1.5 is an old version. If you are still having trouble, please see if the issues go away after updating to the latest version.

I think the update solved it. Thanks so much!