Nwwt's Hebrew deck

That’s bad. Could you try with a new profile (main menu: FileSwitch Profile)?

Unfortunately I don’t have a Mac, but when I try 2.1.50 (final version – the bug was present up to beta 2) on Linux & Windows, the deck’s audio works properly. (Qt just packs Google’s Chromium, which should behave the same here regardless of OS.)

Otherwise, would you check the deck’s options (under :gear:) to see if “Don’t play audio automatically” is disabled?

Do you at least see the button with “:loud_sound:” that ought to appear at the bottom right when auto-play fails? And does other decks’ audio work?

So, when I create a new profile, the audio does work without any issue.

On my usual profile, to answer your other questions,

  • the deck options were set correctly (ie, “Don’t play audio automatically” was disabled)
  • I don’t even see the sound symbol (which is why I thought it was a deck issue, and not a profile issue…?)
  • Audio on other decks works fine

Since creating a fresh profile did the trick, the issue seems to be on my end and not a deck problem, so sorry for the false panic. Now to try to figure out where the settings on my main profile are going awry…

No worries. If you’re not seeing the :loud_sound: symbol that seems to me like an Anki settings issue or problem with the files, since the symbol/button is part of the deck and only gets displayed by its script when Qt’s browser component refuses to play a file or can’t find it.

Or alternatively: If the script fails before that part, but then you would likely also notice issues with card styling – you can check with AnkiWebView Inspector whether it shows any warnings or errors whenever a card side gets loaded. What could also be an issue here is scripts of other decks (but I’m not aware of any): Anki Desktop doesn’t reset the webview between cards, meaning scripts just get requeued – even if they’re from another deck – with potential interference.

If it’s with Anki’s settings, then unfortunately I’m not sure how to help further since I’m not aware of any other Anki audio options to check – those would mostly affect the classic media component (mpv/mplayer) rather than the webview the deck relies on, anyway.

Hi arc709, did you happen to find what caused the issue with your existing profile?

It would be great to know since there might be others affected, and I can’t reproduce it locally.

I haven’t been able to get audio to work for some time in android. I reset my phone and did a fresh install of ankidroid without syncing or adding any other packages. Completely fresh on a wiped phone.

Sorry for long delay all of these notifications are going into my spam and I didn’t see them. I have been very busy so I hadn’t even remembered to check.version 2.15.6 on android, which is what comes from the PlayStore automatically for me.

The deck is outstanding, when the audio works it’s better than a teacher.

Hi true,

AnkiWeb’s mails must be misconfigured, they also land in spam for me. Pure chance I saw your post so relatively soon.

Anyway, thanks for your reply, the screenshot does help. It shows that AnkiDroid does try to play the file, but it’s missing on the phone.

In my experience, that commonly happens when a deck was imported via desktop, and the media sync – which is run separately in the background from the deck sync – either did not finish, or for some reason the file got deleted on desktop prior as well. Said sync is incredibly slow: Done in 25 file batches for no discernible reason – upload is ok, but download to AnkiDroid easily takes an hour+ on the fastest connection. (Often it’s less painful to import the deck on Droid, and run the sync the other way to Desktop.)

Does it play when you re-/preview the card on desktop? In that case, you could try resyncing. If you click the sync button one more time after triggering a sync, it should show you a status window mentioning the media sync state.

No … This was not a synced account or anything. I wiped my phone to factory reset, and downloaded the Anki and Hebrew package directly and screenshotted it without setting up a sync account to the servers or using my email/login. I set it up as a brand new phone user new to Anki. to make sure it wasn’t a syncing error I didn’t even log in or create an account.

I cant actually test it on traditional CPU desktop… For my main desktop I use a Raspberry Pi running the Ubuntu mate environment. Anki, GNUcash, and a bunch of other things load only half-way on the arm64 architecture (which I understand is similar to android) but most of the functionality for those projects seems lost on it (gnu cash has some working functions for instance but can’t run reports ). It is great for the environment and power consumption, so I still love it.

Sorry about that… I think I understand the cause now, though.

It’s actually the importing via AnkiDroid < 2.16 that seems to be the cause. Whereas Anki Desktop imports the apkg’s media without issue, AnkiDroid up to that version had a buggy in-use check – and discarded the audio of this deck.

So either:

  • Import & sync to AnkiWeb via Anki Desktop

  • try AnkiDroid 2.16 (as of writing: still in alpha; downloadable here).
    It seems to finally have discarded its own code and switched to reusing Anki Desktop’s (both media & collection handling: of the former, the new in-use checks seem enabled by default, its rest & the latter still have to be manually enabled).

You can try picking & installing one of the apks (most devices use the arm64-v8a.apk version) and it should finally import fine. It’s best to make a backup of your collection & not to enable the new collection handling yet. When the final version gets released, it will auto-update to it via the Play Store (you can also join the beta there, but that won’t auto-install the current alphas).

edit: Anki Desktop should also work on arm64 nowadays, at least there were numerous commits to its repository working towards getting it to run on the architecture (particularly due to macOS switching from x86 to it). Searching a bit, there is also this repository with instructions how to get it running on Ubuntu arm64. Maybe give that a go (just use the most recent Anki & Python versions over the ones linked there: currently 2.1.54 & 3.10)? Unlike with the Ankidnoid 2.16 alphas, I know the Desktop → Mobile path to work flawlessly, since it’s what I myself have been using for years.

Everything is working again after I downloaded the one from your link. Just excited to have it working again. Thank you so much!!!