Notecard "backs" are cut off or switched to a different card

Hi there, I posted 6 days ago and was told to explain this problem in more detail (specifically as a new post), so here we go.

I downloaded the most up-to-date desktop Anki for Macs, along with the most up-to-date add-on package from Anking around 3 months ago. I have been having this problem from the beginning.

The step by step of what occurs:

  1. I make notecards using either the “type in” or “basic” cards.
  2. When I go to learn them for the FIRST time and I go to answer the notecard, the answer will have been either cut off halfway through the original answer, be blank (nothing is there at all) or the answer is from a completely different notecard.
  3. I will then press “edit” and will fix the notecard.
  4. The notecard is fixed and this problem won’t arise again. AKA it only occurs in the process of when I first make the notecard. But once I go through them all and fix the notecards, they are permanently fixed.

Just to clarify what I mean, if one card was “What is a black and white striped animal” (zebra) and the other card is “What is a gray animal” (elephant). When I go to do my cards it is like, “What is a gray animal” and zebra would show up as the answer. Or it would be like, “What is a gray animal” and Eleph would show up (more like the middle of the sentence, but just using this as an example). So I have to go back and completely redo numerous cards.

The difficult thing is it is extremely inconsistent. There are times I make cards and this doesn’t occur at all, and there are times around 1/3 of my cards are like this. I thought it had to do with the fact I did the “type in” option for my cards, but it is still the case with the basic card.

I have tried holding the shift button down to disable all of the add ons when I make cards to see if it is related to an add on, and I think this mitigates the problem (may be related to a bug in an add on). So I thought maybe I could just make this my “fix.” But I use an image occlusion add-on frequently for my cards, so I’m having to exit out of Anki go back in, do the image occlusion, then exit again, enter without add ons. So this is not sustainable.

Therefore I’m inclining it has to do with an add-on, but going through each add-on to find out what the culprit is seems very daunting and unapproachable. Please let me know what more I can explain or what I can do.

1 Like

Several things, some are related to your problem, some to the way of asking.

  1. If you were asked to explain the problem in detail in an other thread, you could (should) have added the details there, so that you only create one thread per problem (think about future people that will have the same issue, and will re-read the thread trying to find the answer).
  2. Please provide more details. Maybe you haven’t been prompted exactly for which details to add, so I’ll clarify. Provide an exact step-by-step procedure to recreate the conditions that lead you to the bug, and do this without relying on add-ons (ie. try to recreate the bug without add-ons).
    This is a very important step. If you have to remember one thing from my whole post, it should be this. You’ll see that the more precise you are in this step, the fastest the answers should come, and the better they’re going to be.
  3. Somebody suggested to you to disable add-ons. This was only in order to achieve the precedent step, not to use Anki for ever without add-ons.
    However, in the mean time, you may disable only some add-ons (in the add-ons menu), for instance disabling every add-on but the image occlusion one, if you use that one most frequently. This might also allow you to track down exactly which add-on might be causing the bug.
  4. Please, make paragraphs :slight_smile: it’s hard to read you if you don’t.

Don’t take these as criticisms, but as hints on how to be effective when using a forum in general. The best question you ask, the more effectively you will find an answer that suits you.

1 Like

I think that instruction was a bit unclear, to be fair :relaxed:


Hi there. Thank you very much for taking the time to write this in-depth response. I did my absolute best to write as many details as I could, but I guess I needed to try harder. Very new at posting in forums (this is my desperate last resort) so I appreciate your feedback and “hints”. As you saw from the comment, I was instructed to “explain it in more detail on a new post” so I misunderstood–my bad! I tried to edit the post to incorporate my step by step and reasoning for disabling add ons but if this is still not good enough please let me know.

1 Like

I have been having this exact same issue and dont know what to do about it, is there nowhere to be able to contact ANki customer service to be able to deal with this issue? I can’t find any contact other than these forums that arent very helpful for this issue so far

Sorry, “post” wasn’t entirely clear, but @Blmarks did interpret what I meant correctly - as the issue here is different to the one on the original thread, it’s better placed in a new post/thread/topic.

@Blmarks if the issue goes away when add-ons are disabled, that’s good news. In the Add-ons screen, you can select the top half of your add-ons and disable them. If after restarting Anki, the problem is still there, try the other half instead. Once you’ve found the half that is causing the problem, divide that half into half again, and repeat. You should be able to narrow it down in around ~6 steps that way. Alternatively, if you don’t need all the add-ons you have installed, you could start by disabling all the ones you don’t need, and seeing if that helps.


This happens so frequently that it could even be an Anki functionality, couldn’t it? You “record” a sequence of actions, and Anki automatically finds which add-ons trigger an error when “playing” this sequence of actions, by dichotomy. I think it would greatly help beginners to locate the origin of a problem, and therefore would reduce the workload in the forum.

Hi! Because the notecard error wasn’t occurring with every single notecard I made, I felt it would take a while to pin-point the exact add-on, even with the eloquently explained 6 steps listed above. So I switched to only doing “Cloze” notecards, and the error doesn’t happen with these notecards. So if anyone is viewing this post and is having this problem, I would try switching to Cloze notecards!