No answer shown, but response buttons expect a response

Please can someone help me? After using the desktop app just fine for many months, things have now gone wrong.

When I start to study, a few cards display and behave as normal. Then I get a card asking a question, when I press to answer the stored answer does not display. Yet the buttons to respond (again, hard, easy etc) are there. If I press edit, I see the question and the answer. When I close that I may or may not get the card working. Sometimes, I get an answer to a previous card!
I used check database in case of corruption. It reported back ok. Still the problem persists. I updated to version 2.1.47 (dc156f34)⁩. The situation remains.

What can I do? I’ve spent ages putting hundreds of cards in, and was doing fine before this.


Have you tried deactivating add-ons?

Hi, and thanks
I don’t have any add-ons. Looking at the list in the link you provided, the only one still to try is the graphics one.
I’ve also done this: I tried the advice in the Anki manual about checking the data using sqllite. I tried loading a backup. I tried exporting with media then importing this back. I browsed every card to check if I could see any corruption. Nothing helped.
I have found one thing that helps: if I see a blank white screen instead of an answer then press Sync, once or maybe twice, it seems to mostly do the trick - I see the answer and can rate it as usual.
It’s all very strange, isn’t it!
Thanks again

Did you try all three of the video drivers in the preferences screen, restarting each time? If none of them helped, the only thing I can suggest is to see if your video card has a driver update available.

I’ve changed to the ANGLE video driver. I’ve run a good number of cards without the problem happening so far, so hopefully, that has done it.

Thanks for the advice!!