"Next day starts at" : Midnight in the preferences, but 1AM in reality. Why?



I’d like to be able to learn the “cards of the following day” at midnight.
So I specified “Next day starts at 0 hours past midnight” in Anki (and the same parameter in AnkiDroid).
But Anki and AnkiDroid still display new cards only at 1AM, not before.


Between 0AM and 1AM, I synchronized several devices, and none of them displayed the expected new cards :

  • AnkiDroid (my main learning device)
  • Anki on a Linux system (my deck-creating device)
  • AnkiWeb
  • Anki on a Windows 10 system (in a VirtualBox image I set just to do this test)
    (I run the latest versions of Anki and AnkiDroid : Anki 2.1.26, AnkiDroid 2.11.3)

Both my devices know automatically in which timezone they’re in, and which time it is. Everything seems correct.
Currently, it’s “Central European Summer Time (CEST)”.
When it’s “today’s 00:15” for me (UTC+2), at Paris, it’s still “yesterday’s 22:15 UTC”.

I then tried to play with the “2.1 scheduler”, thinking it might correct/trigger something, but it didn’t. No new card was displayed at 00:30. So I wiped this test and rebuild my decks from AnkiWeb.

So, what’s wrong with my Anki’s ?

Is it an old bug in AnkiDroid or Anki that causes that ?
Is it because I sometimes traveled to countries with a different timezone (UTC+1 maybe) ?
Is it because I’m frequently using both Anki and AnkiDroid ?
Is it a current bug in Anki or AnkiDroid ?

If it’s not a bug, do I have to manually correct something in the Anki SQLite database ? (something that is unmodifiable via Anki/AnkiDroid)

I tried to read the manual and do some search, but didn’t find anything useful or explicit.


I recommend you switch to the default 4am, as sleep helps to consolidate memories. You also get the side benefit of +/- an hour not making a difference if you sleep at typical hours.

The issue you’re experiencing should be fixed in Anki already, but AnkiDroid doesn’t support the fix yet.

Hello Damien,

Thanks for your answer and your link (and a huge sincere thanks for Anki).
I’ll check this link from time to time to see if I can help or if the issue is closed.

I usually sleep at typical hours, but I’m one of these crazy people who has thousands of cards, so there are two (exceptional) cases where I find it convenient to be able to begin learning card at midnight :

  • It’s midnight, I can’t sleep because some neighbours are making noise (like yesterday !..), so I’d like to study a few cards to lighten my following day

  • I’m on holiday, I going to bed around midnight, and I know I won’t have much time on the following day, so now is my chance not to have to study my cards the day after tomorrow


If it’s infrequent, an alternate approach would be to keep the default 4am, and use the review ahead option in the custom study screen for the times you want to jump forward.