(New to Anki) Blank Screen on 2.1.49

Hello everyone, I’m new to Anki, just found out about it from a friend that’s in Med School. I’ve installed the newest version for Mac via the website. Whenever I open it Anki is completely blank, like you can see it flicker like it’s trying to load but then just stops. I’ve tried changing preferred GPU to software but still doesn’t work. I’ve tried deleting then reinstalling and that doesn’t seem to work. I’m using a 2019 MacBook Pro 16 inch i7 intel and a AMD Radeon GPU.

Does anyone have a fix for this? I’ve seen something about using Python and I downloaded Python but I have no idea how to use it. Any help would be great!

Just to confirm:

  • are you on the latest version of MacOS?
  • do you have any add-ons installed?

You can try the latest beta (both Qt5 and Qt6 versions).

In another thread a user suggested that opening Anki with a flag to disable the gpu helped them. To try that, open the terminal app, paste the following, and hit enter:

/Applications/Anki.app/Contents/MacOS/anki --disable-gpu

If that doesn’t work, the output from the terminal might give a clue, so paste it here.

I am on latest MacOS Monterrey 12.3

No Addons installed

when i try that i get a permission denied

So i deleted Anki, reinstalled the Qt6 version

ran the command and got this

/Applications/Anki.app/Contents/MacOS/anki --disable-gpu
Anki starting…
Initial setup…
Running with temporary Qt5 compatibility shims.
Run with DISABLE_QT5_COMPAT=1 to confirm compatibility with Qt6.
Preparing to run…

GLImplementation: core_profile
Surface Type: OpenGL
Surface Profile: CoreProfile
Surface Version: 4.1
Using Default SG Backend: yes
Using Software Dynamic GL: no
Using Angle: no

Init Parameters:

  • application-name Anki
  • browser-subprocess-path /Applications/Anki.app/Contents/Frameworks/QtWebEngineCore.framework/Helpers/QtWebEngineProcess.app/Contents/MacOS/QtWebEngineProcess
  • disable-features DnsOverHttpsUpgrade,ConsolidatedMovementXY,InstalledApp,BackgroundFetch,WebOTP,WebPayments,WebUSB,PictureInPicture
  • disable-gpu
  • disable-speech-api
  • enable-features NetworkServiceInProcess,TracingServiceInProcess
  • enable-threaded-compositing
  • in-process-gpu
  • use-gl disabled

Starting main loop…
2022-03-27 21:03:19.347 mpv[26855:458260] This NSLayoutConstraint is being configured with a constant that exceeds internal limits. A smaller value will be substituted, but this problem should be fixed. Break on BOOL _NSLayoutConstraintNumberExceedsLimit(void) to debug. This will be logged only once. This may break in the future.
2022-03-27 21:03:19.354 mpv[26855:458260] Warning: Expected min height of view: (<NSButton: 0x7fdd5bf1c350>) to be less than or equal to 30 but got a height of 32.000000. This error will be logged once per view in violation.
2022-03-27 21:03:19.354 mpv[26855:458260] Warning: Expected min height of view: (<NSButton: 0x7fdd5cd117c0>) to be less than or equal to 30 but got a height of 32.000000. This error will be logged once per view in violation.
2022-03-27 21:03:19.355 mpv[26855:458260] Warning: Expected min height of view: (<NSButton: 0x7fdd5cd12340>) to be less than or equal to 30 but got a height of 32.000000. This error will be logged once per view in violation.

Okay, thanks. Again to confirm, the app is blank, but does the menubar work? Are you able to open e.g. preferences or add-ons? If so, that suggests that the web views are failing to render, in which case could you try opening it with the following command:

QTWEBENGINE_REMOTE_DEBUGGING=8000 /Applications/Anki.app/Contents/MacOS/anki

and then open in Chrome (it has to be Chrome). You should see a list of web views - select ‘main webview’ and choose the console tab. If there are any errors there, paste them here.

Alternatively you could try installing the AnkiWebView Inspector add-on, as it can be used to debug issues with web views, however note that:

  • It doesn’t support the new beta yet, so you’ll have to reinstall 2.1.49 to try it
  • If you can’t open the add-ons dialog (Tools > Manage Add-ons) you can install the add-on by downloading it from GitHub (Code > Download ZIP), unpacking it, and copying the src folder into ~/Library/Application Support/Anki2/addons21

If you can install it, close and reopen Anki, then right click roughly in the centre of the screen, and you should see Inspect. Click it, and then open the Console tab. If there are any errors listed there, paste them here.


Tried the points here? Display Issues - Anki Manual

Are you using an external monitor?

I will try this when I get home from school, thank you for the help!

No I’m not using any external monitors

So i tried doing both these methods, AnkiwebView lets me install it but when i right click nothing happens in the center of screen. The other method when i open Chrome, its Blank as well for some odd reason.

It sounds as if the web toolkit is failing to load for some reason; but it’s unfortunate that it’s not showing any error messages to give us a hint as to why.

One other thing you could try is installing the latest python3.9 from python.org, then running Anki from a terminal with the following: Intro & Downloads - Anki Betas. Does that help at all?

I’m not sure why it’s not loading. Sorry I couldn’t help more, but if you have any trouble starting it from Python as dae suggests happy to help.

Okay I’ll try running it via Python when I get home, if it doesn’t work I’ll just go buy the new MacBook Pro with the M1 Max

1 Like

Which line do I run for Python, I have python downloaded I just have no idea what to do

@grantbradley32 Open the Terminal app, and input the following commands one at a time:

python3.9 -m venv pyenv
pyenv/bin/pip install --upgrade pip
pyenv/bin/pip install --upgrade --pre aqt pyqt6 pyqt6-webengine

@dae the instructions for Mac at https://betas.ankiweb.net fail for me with zsh: no matches found: aqt[qt6]. The above commands work fine. Am I doing something wrong?

Wrapping in in quotes should work: 'aqt[qt6]'

when i type that first line it says zsh: command not found: python3.9

Make sure that you download Python 3.9 rather than 3.10

1 Like

yeah I had 3.9, I fixed this issue, I just upgraded to a new MacBook Pro M1 Max, now Anki works lol

When in doubt, buy a new MacBook :sweat_smile: Glad to have you join us in the glorious era of ARM!

1 Like