Blank Screen - I've Tried Everything

Getting a blank screen after selecting user profile. I am running 11.1 on a Mac Pro (2019).
I have tried:
Checking database - turns out ok.
Deleting the app and reinstalling 2.1.40.
Deleting all addons via the Anki program.
Deleted the entire contents included user profiles in ~/Library/Application Support/Anki and Anki2 folders.
Downgraded to 2.1.35
Tried Beta 2.1.41beta3.
Tried setting Anki to load in low resolution.
Tried changing Anki settings to load video driver as OpenGL and Software.
Rebooted computer several times over the course of troubleshooting.

I have done everything I thought possible and none of the posts on the forums with similar issues are helping. Anyone know something I have missed? I really don’t know what happened. I get no error messages.

I have a complex way to see what’s going on, but it requires some thinking and patience.
a) Open Console app
b) hit clear button and immediataty after that launch
c) immediately when you see the blank sceen, go back to Console app, and use the top-right field to only show anything with Anki as the string

If we are lucky we could see an error message about GPU not being able to initialize or something similar.

Also, upgrade to MacOSX 11.2 as that’s now out. I tend to stay away from major new OS versions until there’s a 11.3 or a similar version myself.

Thanks for the info. I upgraded and from now on will wait for a .3 version before upgrading for certain!

I filtered the search for all processes matching “anki”. I am posting a screenshot of the results. I am interested in the Qt WebEngine not found - not sure if that is a culprit.

I worked in IT for several years so am very happy to do any kind of more complicated troubleshooting steps you might think of.

Those messages are normal I’m afraid.

You could try install Python 3.8 from, then install Anki from PyPi, which will pull in PyQt 5.15.

If it’s broken with 5.15 as well, you could try 5.13 or 5.12

1 Like

Also upgrade MacOSX 11 to 11.2.1 to see if this was an issue with 11.1.

Thanks so much! I finally got around to trying this (in my dedicated period for board prep) and it worked.