Linux: Random crashes while editing with newest Anki version

Hey there!

I’m at a bit of a loss. I’m running the newest Anki .65 on an updated Linux Mint install both on my work computer and at home. Both run great in review and browsing mode, but experience random crashes while I’m editing cards to add to the collection. I tried checking the database, which was okay. I tried a Windows computer and it worked fine. I tried disabling all addons and it still crashed. I also tried installing Qt5, which, on my Mint, just opens up with a completely blank screen.

Guys… I’m out of my depth here. Since Anki is my main computer tool, I’m actually considering switching OSes to keep it running, but thats a lot of work and I have 2 babies to take care of on top of trying to study for an exam. Any help would be greatly appreciated!

You could try software mode in Qt6 (Display Issues - Anki Manual), or a workaround for Qt5.

Thank you! I will look into that.

For what it’s worth and anyone else suffering from the same problem, I may have found a workaround: I tried the flatpak Anki version and so far I had zero crashes on it. I used to manually install Anki from the webpage, but I figured that may be a source of version conflict. I was eyeing QT6.

I can’t prove anything, but anyhow, for now, I’m sticking to the flatpak and enjoying my Anki.

FYI, I’m having the identical issue, on MacOS.

I’m a very long-time ANKI user, for more than 10 years (it’s the most frequent app I use on iOS!). But on desktop (MacOS) - since the latest upgrade a few weeks ago - it crashes a few times a day :frowning:

Thank you so much for all the hard work making and maintaining this app!

Maybe this helps you out: I ended up getting the same crashes again on the flatpak. In the course of investigating, I found out that it mainly crashes when I copy and paste stuff around in a note, so I opened a new topic here and one of the devs suggested I try the current beta which adresses, among other things, the copying and pasting.

I’ve been running that beta for a couple of days now and haven’t had a single crash, so i guess my specific problem was fixed. Maybe you want to check out that beta too?

In addition to trying the beta (Anki 2.1.66 Beta), it would also be worth trying to reset window sizes in the preferences screen.

I too am having a similar issue trying to copy and paste while making cards and Anki crashing. Everything else works great. I have updated to Anki beta and reset window sizes and the problem persists. Any other suggestions? I am on a MacOS.

I’m surprised the beta didn’t help - did you confirm the upgrade worked by checking the version in the about screen?

Other things could try are the qt5 version, and disabling any third-party tools like Grammarly that you have running.

Yeah I confirmed I updated to the beta version. I have a mac M1 and I don’t see qt5 version for this device. I quit any third problem tools like Grammarly and still ran into the issue of it crashing every couple of cards I try to add.

It seems to be okay when I have disabled all my add-ons by holding shift when opening. Is there a way to see which add-on is causing the problem?

You’ll need to disable half your add-ons and see if the problem persists, then repeat to narrow it down.

Thank you! That seems to have done the trick. A couple of friends and I have had the same issue and narrowed it down to the “Searching PDF reading-Note-Taking in Add Dialog” add-on causing the problem if that helps anyone else.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.