Learning cards in the 2.1 scheduler

Hello everyone.

I have 23 cards in this filtered deck (meaning 23 Due on the home screen)

I pressed “again” on some of these cards, the total home menu Due count should remain the same (23), right? Because I’m not done with these cards yet and they’re still due in 10 mins.

But in the home screen the Due count doesn’t remain the same i.e. it decreases by the total number of cards I pressed “again” on.

Was this already the case? Or is this new?

I have Anki 2.1 scheduler turned on.

I guess what I’m trying to say is the Due number on the home screen only shows the To Review count and NOT the Learning count.

Edit: this issue is not present when the scheduler is turned off.

Edit 2: when the scheduler is turned on, the time spent studying material whilst the “Reschedule cards based on my answeres in this deck” option NOT ticked, doesn’t go towards your total session time.

Apologies if all this is meant to be the way it is. I only just noticed them

Here are the pictures to explain it better:

The deck list will not show counts of cards that are not ready to study, so you can see at a glance which decks need attention.

No review log entry is currently created when rescheduling is disabled. This may change in a future release.

1 Like

So, after the 10 mins have passed, they’ll appear in the home screen Due count? Because I tried to do that, but still the same thing happens. It works just fine without the filtered decks though (the home Due count shows the Learning count + To Review count). Apologies for any misunderstanding.

Sweet stuff, thank you for the help!

Would you mind creating a small reproducible test case for me? If you can share an .apkg file with a few cards, or tell me the steps I should take using your AnkiWeb collection to trigger the issue, I’ll look into it.

I don’t use AnkiWeb unfortunately. But I extracted the deck and sent it as a message. Thank you for taking the time to look into this.

Import the deck I have attached. All you you need to do is:

  1. Turn on your Anki 2.1 beta scheduler

  2. Create a filtered deck and use the the following search criteria: deck:“Test” is:new

  3. UNCHECK “Reschedule cards based on my answeres in this deck”.

  4. Change the “Repeat failed cards after x mins” to ONE. This is to avoid waiting for 10 mins.

  5. Now, on the study deck screen you should have -> New: 0///Learning: 0///To Review: 23

  6. Press D, and note down the “Due” number which should be appearing next to the filtered deck which you just created. It should say 23.

  7. Go back inside the filtered deck, and start studying. Press “again” on TWO cards (it can be any number of cards, this is just for demo).

  8. Press S to go back to the study menu, you should now have New: 0///Learning: 2///To Review: 21

  9. Press D and look at the number of “Due” which should be appearing next to the filtered deck. After the time has passed (1 minute. Maybe wait for 2-3 minutes, to REALLY ensure that the Learning cards are due?), you would expect the count to go back to 23, right? Except this is not the case. Right now you should have 21, even though the cards in the Learning phase are now REALLY due.

Repeat the above with the beta scheduler turned off, you will NOT get the same result.

(May be relevant or may not) A couple of things I’ve noticed whilst doing the above:

  1. When scheduler is turned ON: doing the steps above will make Anki think that the cards are “To review”(New: 0///Learning: 0///To Review: 23). Whereas when doing it with the scheduler turned OFF, Anki will see them as “New” (New: 23///Learning: 0///To Review: 0)

  2. When doing the steps with the scheduler turned OFF, after pressing “again” once, the Learning count increases by the number of learning steps rather than ONE. Again, this is not the case when the scheduler is turned ON. Is Anki counting the number of remaining repetitions in this situation?


Ah, if you have turned rescheduling off, cards are placed in a special “preview” queue that is not currently handled by the deck list. I’ve made a note to fix it, thanks.

And yes, the old scheduler counted remaining steps instead of cards in learning.

1 Like

That’s some good stuff. Thank you!