Anki Forums

Japanese Support

If you encounter any problems with the Japanese Support add-on, please post them here.

If you wish to submit changes, please see https://github.com/ankitects/anki-addons

Hello, thanks for the add-on, it works great. I just wanted to ask how I could type kana reading when giving the answer. I tried {{type:kana:Reading}} but it is the same as if I put {{type:Reading}}. Sorry if it is a dumb question, I really don’t know much about programming / writing.

I’m afraid the type-in-the-answer code doesn’t currently support field filters, so it’s only possible to type in the original field contents at the moment.

I’m having an issue creating both card types for my Japanese notes. This used to work fine and I’m not sure what happened, because now when I create a Japanese note, even though I have both card types listed (recognition and production) it is only creating recognition cards. In the preview before the note is added both cards look fine but after I hit “add” it only adds recognition, and when I try to open the production card, it tells me the fields are blank even though they are the same fields used to create the recognition card. This issue happens both with the desktop version for Mac and the Android mobile version.

I’d really appreciate any help on how to fix this issue since it’s really affecting my ability to add new words to my study regimen.

Your second card template is set up to be optional, so you need to put some text like ‘y’ in the production field if you want the second card to be generated.

Thank you so much! I was going crazy trying to figure out what was going wrong. Is there a way to set it so the second card is generated by default?

Yes, remove {{#Production}} and {{/Production}} from the template (Cards… button in the edit screen)

Is there a github repo for this add-on? I would like to submit a pull request.

1 Like

I’ve updated the initial post to link to it.

1 Like

Hello, thanks for creating this add-on, yet recently I have encountered issues with it. First when I type in the Expression field, the furigana won’t come out automatically, but the Reading field is already there. Secondly something like this keeps popping out despite numerous re-installation and restarts

Caught exception:
Traceback (most recent call last):
File “aqt\webview.py”, line 34, in cmd
File “aqt\webview.py”, line 114, in _onCmd
File “aqt\webview.py”, line 518, in _onBridgeCmd
File “aqt\editor.py”, line 393, in onBridgeCmd
File “aqt\gui_hooks.py”, line 1202, in call
File “lib\site-packages\anki\hooks.py”, line 594, in runFilter
File “C:\Users\VC\AppData\Roaming\Anki2\addons21\3918629684\reading.py”, line 223, in onFocusLost
n[dst] = mecab.reading(srcTxt)
File “C:\Users\VC\AppData\Roaming\Anki2\addons21\3918629684\reading.py”, line 86, in reading
self.mecab.stdin.flush()
OSError: [Errno 22] Invalid argument

Is there anyway I can do to fix this? Thank you!

Have you ruled out both of these as the problem? What is your Windows username?

If you’re receiving errors about mecab, you may need to add an exception to your antivirus program for mecab.exe

If you receive a message about non-Latin text, it is because the reading support does not work when your Windows login name contains characters from other languages. If you create a new Windows login using A-Z characters, or rename your existing login folder (for advanced users only!), it should resolve the problem.

Hi!Thanks for the reply, and yes I have already ruled out both of the above mentioned problems. Is there anything else I can do to solve this?

Please see https://anki.tenderapp.com/discussions/ankidesktop/16366-error-trying-to-generate-readings

What antivirus program are you using? What do you see when running mecab.exe outside of Anki?

Hi, sorry to bother. I downloaded the add-on but somehow it not showing anywhere. I can see it when I click the add-on option on the tool section but when I want to add a new card, I can’t find the note type for japanese and furigana I don’t know why :(( I’ve already tried to delete it and download it again but it still doesn’t appear

p.d. I have the lastest version

Please make sure you restarted Anki, and added the note type by clicking on the Manage button as described in the instructions.

Hi there, first I want to say thank you so much for this amazing add-on. It has helped me so much. However, since yesterday I have been having some issues with it. I was able to come to the conclusion that this add-on was causing the below message to appear (by disabling other add-on’s until I found out it was this). The trigger is when I open Anki, try to add a new card, and then after typing in a new word in the “expressions” box I click tab to go to the next input box, and instead of smoothly allowing me to type there like usual, it delays for a few seconds, without inputting any furigana in the “reading” section. And then after about 10 seconds the below error message pops up.

This morning I tried to fix it by restarting my laptop, and it actually worked. But, this afternoon the problem came back, and restarting my laptop hasn’t solved it this time ):

I would truly appreciate your help in getting it to work again. It is by far my favorite add-on in anki.

Error
An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue on the add-on support site.
Debug info:
Anki 2.1.22 (0ecc189a) Python 3.8.0 Qt 5.14.1 PyQt 5.14.1
Platform: Windows 10
Flags: frz=True ao=True sv=1
Add-ons, last update check: 2020-08-22 10:45:17

Caught exception:
Traceback (most recent call last):
File “aqt\webview.py”, line 31, in cmd
File “aqt\webview.py”, line 97, in _onCmd
File “aqt\webview.py”, line 500, in _onBridgeCmd
File “aqt\editor.py”, line 363, in onBridgeCmd
File “aqt\gui_hooks.py”, line 1006, in call
File “lib\site-packages\anki\hooks.py”, line 622, in runFilter
File “C:\Users\humza\AppData\Roaming\Anki2\addons21\3918629684\reading.py”, line 223, in onFocusLost
n[dst] = mecab.reading(srcTxt)
File “C:\Users\humza\AppData\Roaming\Anki2\addons21\3918629684\reading.py”, line 86, in reading
self.mecab.stdin.flush()
OSError: [Errno 22] Invalid argument

So each time you restart your laptop, it works for a while, and then stops working? The error seems to indicate the tool Anki uses to convert the kanji is failing. Do you use a third-party antivirus program?

Hi there Dae thanks so much for responding so quickly, I only just saw your reply.

Actually, the method of restarting my laptop only worked once a few days ago when the issue first arrived. Since then restarting hasn’t made the issue go away. (Perhaps that indicates the first time was a fluke?)
And to answer your question, no, I just have the regular “windows defender” that is built into windows 10.

Please try removing the add-on and reinstalling it. Does that help? If not, is there a mecab.exe file in the add-on’s folder?

Just did that now! When I restarted Anki to activate it, the same error happened again so I thought nothing changed. But after closing Anki one more time, and trying again, it works now!!
It seems pretty unstable for now so I might need to message you again if I can’t resolve a future issue by myself.
Thank you for your help Dae!