Issues with the V2 scheduler and new timezone option

I just updated from 2.1.22 to 2.1.35.
On 1/21 I did all my reviews for the day. Then I synced.
Then I updated to the v2 scheduler.
All my cards that were due tomorrow showed due as today on the desktop app (ankidroid still was fine).
Thinking it was just off by a day, I tried added 1 day to my ivl of all of my cards. I now was back down to my proper 0 reviews for today and 330 cards for 1/22.

On 1/22, It now showed I still had 0 reviews due. But now it showed I had 330 cards due for tomorrow. So I changed the ivl of all my cards again, to set them back down by one day. Now it’s showing that I have all of 1/23’s cards due today.

So I ticked the beta timezone option. Now everything seems fine. But I can’t use ankidroid at all anymore.

Either I untick the beta timezone option, and have tomorrows cards due today, or I tick the timezone option and can’t sync w/ ankidroid.

The V2 scheduler change was the piece that broke my due dates, and the only option was to use the new timezone option. Is there a better way to handle this on the desktop app? Or was there something I did wrong here?

In summary, my timezone has been incorrectly updated by updating to the V2 scheduler. It can only be fixed by enabling the new timezone code. Is there something I did wrong here or is this a bug?

You may be able to work around the issue by shifting your “next day starts at” forward or back a few hours. If not, you’ll need to use the old scheduler until AnkiDroid catches up. They are hopefully not far off at this point, thanks to David’s hard work.