Issue with Filtered Deck reviews

So I have one large deck that I make filtered decks from to study for clerkship/shelf blocks. Upon making the filtered deck there are ~1000 new cards and ~700 reviews (I am assuming these reviews are from an overlap of tags from other cards that are overdue within the original deck).

I have tried doing all of the reviews so that they can return to the original deck, but the following day, when I choose to rebuild, the same ~700 cards return as reviews. And the scheduling/intervals haven’t changed from the previous day even though they all should have graduated a level.

Hopefully, I made this clear enough. I’m scared of doing new cards in this deck because I do not know if they will end up in this large pile of reviews that keep returning every day.

Your filtered deck search should include (is:due or is:new) if you only want it to include reviews that are ready for review again, or otherwise reviews will be shown early.

Thank you for the quick reply! So I have tried is:due and is:new but the same ~700 reviews keep returning. This is what my filtered deck looks like:

(“tag:#AK_Step2_v4::!Shelf::FM” or “tag:#AK_Step2_v4::!Shelf::FM::") -tag:#AK_Step2_v4::!NotDoing -tag:#AK_Step2_v4::!POTENTIAL_DUPLICATE or (“tag:#AK_Step2_v4::#Resources::FM” or "tag:#AK_Step2_v4::#Resources::FM::”) -tag:#AK_Step2_v4::!NotDoing -tag:#AK_Step2_v4::!POTENTIAL_DUPLICATE is:new

It sounds like you didn’t enable rescheduling in that deck.

I have the 2.1 scheduler enabled in preferences. I do not know what is happening, but the more new cards from this deck that I do, the larger this recurring “review” deck gets. Am I creating the filtered deck incorrectly?

I’m referring to this checkbox:

grafik

If it’s unchecked, reviews you do in that deck won’t have any effect on the cards’ dueness, intervals, etc.

Oh yes, I have this checked too.

Upon a closer look, the issue seems to be with your filter. OR has a lower precedence than AND, so your search means:

"Any cards matching this: (“tag:#AK_Step2_v4::!Shelf::FM” or “tag:#AK_Step2_v4::!Shelf::FM:: *") -tag:#AK_Step2_v4::!NotDoing -tag:#AK_Step2_v4::!POTENTIAL_DUPLICATE
And any cards matching this: (“tag:#AK_Step2_v4::#Resources::FM” or "tag:#AK_Step2_v4::#Resources::FM::* ”) -tag:#AK_Step2_v4::!NotDoing -tag:#AK_Step2_v4::!POTENTIAL_DUPLICATE is:new"

So cards matching the first part will be included, regardless of whether they’re new. To fix this, you could wrap everything except is:new in brackets.

2 Likes

I get this message when I try to use brackets “The provided search did not match any cards. Would you like to revise it?”

This was my search: [(“tag:#AK_Step2_v4::!Shelf::FM” or “tag:#AK_Step2_v4::!Shelf::FM::") -tag:#AK_Step2_v4::!NotDoing -tag:#AK_Step2_v4::!POTENTIAL_DUPLICATE or (“tag:#AK_Step2_v4::#Resources::FM” or "tag:#AK_Step2_v4::#Resources::FM::”) -tag:#AK_Step2_v4::!NotDoing -tag:#AK_Step2_v4::!POTENTIAL_DUPLICATE] is:new

I mean these guys: ()

2 Likes

That worked! Thank you so much!!!

1 Like