Issue with Displaying Intervals in Anki





Hello everyone,

I’m experiencing an issue with Anki, and I hope someone can help me out. The problem involves the display of intervals for my cards. I’ve set learning steps for new cards, starting with 5 minutes, then 2 hours, and finally 10 hours. The problem arises when I go through the learning steps and reach “Interval for Graduating.” At this point, the intervals are not calculated correctly. It consistently stays at “1 day” and doesn’t increase. Sometimes, the “10 hours” step is also skipped, jumping directly to "1 day.

That part is easiest to explain. If your 10h step will cross the day boundary (like when you study at 00:51 – assuming your day boundary is the default 4am), it will be converted to 1d. Deck Options - Anki Manual

Looking at your 2 examples, it’s not immediately clear what happened.

For Card “A” –
image
I’ve only seen this when a card gets introduced again and studied on a different platform. Is it possible you studied it in one app on 1-21/22 and then without syncing, studied it in another app on 1-23? Was there something else between 1-22 and 1-23 that could have caused the card to revert to New?

For Card “B” –
image
I’m not sure how you studied it 4 times in the same minute! Is your Learn Ahead limit (Preferences - Anki Manual) set for a very long time? But whatever happened when you studied it in the Filtered deck depends on that deck’s settings involving rescheduling and returning.

As far as your add-ons – I’m not familiar with every one of them, and most of them look pretty mild. But one of the first things you should do when you notice a problem is see if Anki behaves the same with your add-ons disabled. Troubleshooting - Anki Manual

1 Like

Thank you for the detailed explanation!

Regarding the issue with the 10-hour step, I understand now that it might be related to crossing the day boundary

For Card “A,” it’s possible that the card got introduced again and was studied on a different platform without syncing. However, I want to highlight my uncertainty in this case, as I have a feeling that I am repeating the same content multiple times. ( I frequently imported backup copies to check if the same issues persist perhaps this could also be the cause)

As for Card “B,” I created a custom study session for testing purposes with the same deck settings to observe how the intervals increase. Despite setting “Reschedule cards based on my answer in this deck” and pre-learning for 10 days, the intervals remain at 1 day. However, I believe that the intervals should still increase here and not remain permanently at 1 day

I also don’t understand why the answer “hard” is 1d. Shouldn’t that be lower? and not the same as the “good” button
hard

If you are studying on different platforms, the cardinal rule is to sync at the beginning and end of every study session. That’s the only way to make sure your collection stays in sync everywhere.

If you are importing backups with different scheduling data, that could definitely also explain the inconsistencies.

By “pre-learning” – do you mean this was a Custom Study “Review ahead” deck? That explains it. That’s not a good test situation to figure anything out, because it’s designed to take into account that the card is being reviewed early. Filtered Decks - Anki Manual That’s what caused repeated 1d intervals for that card.

It’s because that interval crosses the day boundary, same as above. This looks like a card in learning, so Hard will be halfway between Again and Good. Studying - Anki Manual I can’t tell which step you were on, but if it was 2h – Hard would be ~5h – if it was 10h – Hard would be about 12h. Either one of those could cross the day boundary, depending on what time you study.

But this “1d” interval doesn’t mean you have to wait 24h to see the card – it’s the opposite. The card will be available to study with all other cards that are due that next day – starting at 4am or whenever your day boundary is.

1 Like

Hello Danika_Dakika,

I just wanted to give a quick update. I finally figured out what was causing the problem thanks to you, and now everything is working as intended. Over the last few days I’ve moved my study times from the usual early mornings to late evenings/nights. This has led me to believe that my intervals were not working properly, but it was actually due to the day boundary. Thank you all for your support and advice! :laughing:

1 Like