iPad screenshots should resize when pasting into Anki

I’m using the eminent PDF Expert on the iPad and would really like to work with Anki alongside. But unfortunately the screenshots taken from the iPad becomes way to big.

What have I tried?
This: https://docs.ankimobile.net/#/more?id=image-resizing
I put the limit to 512px width, it doesn’t work, seems 1024x is the minimum? Also, pasting the image (with the resize feature) would be a 100 times faster workflow then having to import it from Photos…? And also to be able to control the max height.

Just to be clear, I don’t want to change the images during review by changing any template, I want the images physically(!) smaller. It’s all about UI and sync speed (I’m prone to add a lot of images). Believe it or not but there is a noticeable annoying delay on AnkiDroid when showing cards with to big images (e.g. the ones coming from iPad), you can even visually see how the UI scales down the image. This is not me dissing AnkiDroid, that app is the best ever, it’s just my phone is quite old. But since this is merely a software issue I’m definitely not planning to upgrade phone, it works perfectly fast with decent image sizes.

I guess my post can be summed up like this:

  • Resize image from screenshot on paste(!), according to user defined upper(!) limit on both width and height?

Thanks for the suggestion, I’ll look at extending this behaviour to include pasting in the future.

Thanks Damien!
I’ve been using the Anki platform for around 7 years now and this is the first time I’m actually missing a feature… so that’s very good reviews. The iPad (especially the bigger Pro 12.9) is starting to become a very potent device that one can actually do serious work on, the multitasking is becoming better and better.

About the 1024px limit, is this by design or is it actually possible to lower it? I tried to follow the instructions as closely as possible. Because without that feature in place the pasting feature would be worthless (at least for me).


There’s no explicit 1024px minimum. The setting applies to the longest edge, so maybe picture was taller than it was wide? Or maybe the image is in a retina resolution, so takes double the resolution to display at a specified size.

Sorry for late reply. Been sick, and busy.

I just now tested the “Image Resizing”, and lo and behold it works! But only after I changed the max down to 256px. Super weird, it was like a toggled a switch or something…??
Just 10 minutes before 256px I tried with 512px…didn’t work.
I’ve been very meticulous and have followed instructions step by step:
(Open Anki desktop->Debug Console->Type in and run cmd->Sync Anki Desktop->Sync AnkiMobile->Add dummy card with image->Sync->Etc…)

Either it’s some small logical code bug, or I’ve missed some step along the way (the latter is probably much more likely!).

As a bonus, now that my max size is not ignored I also see that it works for the height, wonderful! Getting the paste-feature is the only thing I miss now, that would be a killer-feature saving a lot of time!

But, one thing I noticed however is that the screenshots taken from my PC/Win10 (1920x1080) have much better clarity compared with screenshot coming from my iPad Pro (2732x2048), at the same final resolution. The PC image sizes are also around 10KB smaller. I’m using the default way to capture screenshot on both PC and iPad. Can this have to do with which compression system AnkMobile uses?


AnkiMobile currently use a higher compression ratio than the computer version; I’ll look at making it consistent.

PC/Win10 (645x333 px, 29,73 KB):

iPad Pro (720x357 px, 41,4 KB):

Ok I see! It’s promising that you have already figured out the cause.

I show an example in the previous post, maybe “the web” will compress it even further and they will be indistinguishable once uploaded, but hopefully not. Note that the iPad screenshot have an extra black bar in the bottom, I got more than I wanted, but it shouldn’t add more than a few bytes on the image size.


An option to resize on paste will be in the next beta, please let me know if you’d like to try it.

Ok awesome!
I just post a private ticket.


Hi again!
I have now had some time to test the new “resize-on-paste”-feature that was added.
It works! :+1:

But…it unfortunately upscales images :confused:
I don’t think this is the best approach. I pasted a perfectly clear 219x179 image that I found online, which became very blurry at 500 (my current limit).
The logic should be to downsize images I have no control over (e.g. screenshots taken from iPad which will be huge because of the high resolution) to my “Max Image Size (Long Edge)”, but keep size from all the rest (e.g. images copied from Google where the pixelsize is know and I have control over).

One more thing I noticed is that it takes one extra sync between dekstop Anki and iOS Anki to make the changed image size stick. So in other words if I change it on iOS Anki to 500px, sync to server, open dekstop Anki (where I already changed to 700px), sync to server, then when opening iOS Anki (and syncing) it switches to 700px. At least I think that this is what happens. To be sure I just ran an empty console command in hope it would clear any setting I might have lurking on desktop Anki.

Btw is this the correct place to post beta feedback?

Thanks for letting me know, I’ll add a check to make sure it doesn’t increase the size in the next update.

The webview may be caching images - if it happens again, please try forcing the app closed and restarting it.

Superb, thanks!
Maybe an on/off switch in the settings. Some folks maybe desire the upscaling, even though I assume they are very very few.

Regarding the different compression I experienced between Win10 and iPad Pro, has this been tweaked?
I still get better clarity on Win10 screenshots and smaller file sizes (even with bigger image resolution), compared to iPad. But I feel it has been improved a little…? I did use different images last time though, with more text in them, so maybe that’s the reason they look more similar now.
Win10 has an unfair advantage though compared to iPad because the images I’m “snapshotting” from Win10 gets the exact resolution without any scaling, I accomplish this by setting the zoom level in SumatraPDF to 150% and then I get images approximately around 500px width. I have a 1920x1080 monitor. I suppose Anki then only has to do the compression, and not scaling, whereas for iPad both has to be done which results in images being more blurred. I’ve set desktop Anki to paste images as jpg to keep the file size down, a feature I sadly found out only a little while ago. I have lots of unnecessarily huge .png’s in my database!

I did adjust the compression level to 80% to match the computer version in the latest update. I think you’re right in your assessment - having the image already at the desired resolution on your computer is likely contributing to it looking better.