Inputting unicode alt codes produces extra letters

When typing a unicode alt code (such as +3105), the pressed numbers don’t get typed and instead you get the character ㄅ. But when you type a code that includes a letter (such as +310A), you are supposed to get the character ㄊ, but instead you get Aㄊ. It seems like numbers get ignored while holding alt, but letters don’t, leading to them being typed in addition to the character you want.

Note: In order to type unicode alt codes on Windows, you need to edit your registry and add a new string called “EnableHexNumpad” with value 1 in “Computer\HKEY_CURRENT_USER\Control Panel\Input Method” and reboot your PC. Then when typing, you hold alt, and press + and the hexadecimal unicode value of the character you want.

Is this bug specific to Anki? I mean, do you experience this issue only when working with Anki, or on other applications too?

This is indeed specific to Anki, other applications completely ignore both numbers and letters.

Worth mentioning is I tested this on both the Qt5 and Qt6 version of Anki 2.1.54.

There are known issues with the toolkit’s handling of Alt input. Adding/Editing - Anki Manual