Anki Forums

Persian half-space character

Persian half-space isn’t working in 2.1.28 beta 3.
the shortcut key for that character (in persian keyboard) is Ctrl+Shift+2 which is working in other apps, and if i write that character in other apps and then copy it and paste it into anki field, it works.
Decimal character code: 8204
Hexadecimal character code: 0x200c
HTML: ‌
java string: \u200c

1 Like

I presume it works in the -alternate version? Sounds like yet another toolkit bug.

just tested it on alternate version. doesn’t work either.

I presume you have ruled out add-ons? What’s the newest Anki version it did work for you in?

disabled all add-ons temporarily on the alternate. changed nothing.
2.1.26 is the last version that i have and i can type that character in.
it doesn’t work in 2.1.28 alpha3 (don’t have other alpha versions, i can download and test them too if it’s necessary)

Same in both the add screen and browse screen? I can’t see any shortcut changes that would explain it - surprised the alternate version doesn’t work. What Qt version is shown in the 2.1.26 version you’re running’s about screen, and what version do you see when running the beta alternate?

i can type the character in browser search bar but not in browser edit fields.

Version 2.1.26 (70784154)
Python 3.8.0 Qt 5.14.1 PyQt 5.14.1


Version 2.1.28 (93425be8)
Python 3.8.0 Qt 5.15.0 PyQt 5.15.0

5.15 indicates you’re using the non-alternate version - it should say 5.12 IIRC.

i re-installed the normal version after i tested other versions and the first version that i tried was .28 alternate, didn’t change anything.
i’m gonna re-install it and see if i can type that in browser edit fields

i tried all of them, beta 1, 2, and 3.
even uninstalled anki before installing alternate versions. the only thing that i haven’t tried is restarting my pc after uninstalling anki then installing alternate version.
in programs an features it says that i have the alternate version installed image
but in about, all of them have the same Qt version:

Version 2.1.28 (93425be8)
Python 3.8.0 Qt 5.15.0 PyQt 5.15.0

actually just uninstalled it from programs an features and tried to open anki to see if it actually has gotten uninstalled, anki opened. gonna uninstall it from the uninstall.exe file in anki folder and try again.

1 Like

uninstalled if from anki folder, and installed the alternate version afterwards. it works.

Ok, thanks for testing. So, toolkit bug :frowning: Hopefully they’ll fix it in the August update.

1 Like