# Problem typing curly brackets (and other characters too...)

I recently updated Anki (it has been quite a while) and noticed that I couldn’t type certain characters (curly brackets, square brackets and backslash) in the card editor anymore.

Here’s what I’ve tried to solve the problem:

  1. I tried to find out whether the problem occurs in other programs. It doesn’t.
  2. I tried to deactivate all add-ons.
  3. I tried to update to the latest version of Anki. (2.1.30)
  4. I downgraded my Anki version to 2.1.26. In this version the problem doesn’t occur .

I didn’t receive any error messages that seem to relate to this problem.

As I am german, I am using a german QWERTZ keyboard layout . In order to type the characters that I’ve mentioned before, you have to use a key combination with either Ctrl+Alt or Alt Gr. Maybe that’s important.

I am using a Laptop and a PC, both with Windows 10. The problem occurs on both machines.

I’ve discovered that the problem occurs with Anki versions 2.1.28, 2.1.29 and 2.1.30 .

I hope that there’s a fix to this problem.

Thanks for the help guys…

It should work with AltGr - does it not? If not, you can try the -alternate version on the download site, which uses an older toolkit.

1 Like

I switched to the alternate version of Anki 2.1.31. Everything works fine there.