2.1.28 prevents me from typing any Hawaiian characters

I updated to 2.1.28, and I can no longer type any Hawaiian characters in Anki. This is a problem with 2.1.28.

  • I was capable of typing Hawaiian characters in 2.1.27.

  • I am still capable of typing Hawaiian characters in every application except Anki.

  • The problem persists even when I start Anki with all add-ons disabled.

  • When I try to type ā, Ā, ē, Ē, ī, Ī, ō, Ō, ū, or Ū into a card, absolutely nothing happens in Anki. The characters do not show up. Anki responds as if I had not typed anything.

  • I can still copy and paste these characters into Anki without problems.

  • The problem persists when trying to edit cards in the browser, the add window, and the edit window.

  • I CAN type Hawaiian characters into Anki when doing things like renaming decks or changing the learning steps

  • In the browser search bar, all the characters work except for ā and Ā, which still do not work.

  • The 10 characters in question are normally typed by shifting to the Hawaiian-language keyboard setting, and then holding down the right alt-key while typing the letter. e.g. “ā” is typed by hitting right-alt + “a.” “Ū” is typed by hitting shift + right-alt + u.

Thank you for any help you can provide!!

had the same problem with some Persian characters. here’s what Damien said:

toolkit bug :frowning: Hopefully they’ll fix it in the August update.

you can use the alternative version until then.

Please let me know if the latest beta does not fix it.

I tried using Version 2.1.29 (61e8611b), but that does not fix the problem. I am still having all of the same issues trying to type the Hawaiian characters.

Hmm, that’s unexpected.

@mmdj2 did beta2 fix the AltGr issue for you?

I still can’t type half space.

Sigh, looks like it was working in 5.14.1 but not .2. Thanks for testing; please keep using the alternate or workaround until the next beta.

Ok, I’ve built a new beta2 version for Windows - please let me know how that goes.

i still can’t type half space.
(but half space doesn’t use AltGr, so maybe it has solved altgr problem?)

Unfortunately, the problem persists even when I am using Version 2.1.29 (ca8265a6).

@AnkiJeopardyHelp Please let me know how you go with beta3; I’ve hopefully solved it this time.


Thank you! The problem is fixed in Version 2.1.29 (15c9cd91).

1 Like

Great, thanks for testing.