In Study Input Mode All Keyboard Shortcuts Still Active

I think this may have to do with an Anki or add-on setting but much as I try I can’t determine how. The problem also persists on and IOS when the deck is uploaded.

This only happening with add-on Overlapper which I had running on both compatible Anki versions 2.1.28 and 2.1.38. I tested with both versions with the same result.

I used the ‘Downgrade and Quit’ menu selection for before downloading and using each of the older versions.

For all these versions 2.1.49 and older versions I can create a deck that in the browser’s '‘Preview’ mode that appears to be correctly rendered front and back.

When I then go into study mode the card type cloze fields are displayed as expected. However I cannot type into the fields and if I type an ‘e’ key for example I’m immediately put in the note ‘edit current’ mode - other keys like ‘b’ put me 'browse mode and ‘d’ takes me back to the deck listing. So all shortcut keys are still active and the cloze input field is not.

If I click ‘show answer’ without doing any text input the answer screen appears and it shows the answer page correctly.

So somehow my keyboard is stuck such that all the Anki shortcut keys are still active and the keyboard input to the current cloze field is not active.

Finally I toggled all my add-ons to be disabled during the tests except for the overlapper add-on and I did an update request for overlapper when running the older Anki versions and no update was done.

I’m not familiar with the add-on, but in stock Anki, cloze deletions don’t require you to type in the answer by default. If you attempt to type text in the review screen while a text input box is not visible and focused, those keys will be interpreted as shortcuts.

Thank you for the reply Dea !

I did some checks based on your reply and found that in cloze fields where I can type into the card template contains the statement {{type:cloze:Text}}.

I did a search of the the add-on card templates I was expecting to be able to type into and they do not contain that statement.

So looks lie you’ve solved my problem which was that I was expecting more from the add-on than it was designed to do.

Thanks again for helping me along the Anki learning curve.

1 Like