Imported Data Not Showing Up In Target Deck

Hello! I am importing data into the Anki desktop program and I am getting lots of notifications from the app that the data has been imported successfully. However, the data is not actually showing up in my target deck (or any deck). So, I am looking for advice.

***In case it’s helpful, here’s some background on what I’m doing:
I use Anki to learn the backgrounds of students in my class. I create the decks on my laptop but then test myself on the mobile app. To create the decks, I download data from my school’s website, turn it into a .txt file, create a new Anki deck, and import the .txt file into the new deck. I have done this many times before, but it is not working today.

***Here are all the notifications I’m getting, which suggest that the data import is successful:

  • When I click File → Import, a file import preview screen opens up. When it does, I can see that the correct data is appearing in the correct fields.
  • Then, before pressing “import” I am double checking that I have selected the correct notetype and that I have selected the correct deck as the location for importing.
  • Then, when I press “import” a new tab opens up saying “65 notes were used to update existing ones.”
  • That new tab gives me the option of looking at “Details” of the data that was updated. When I click on the details, I can see the 65 rows of data that were uploaded as 65 cards.

***But here’s the problem I’m experiencing:

  • The cards are not showing up in the deck that I designated as the target deck.
  • In other words, the deck is empty–there is nothing to browse and nothing to test.
  • Also, the cards are not showing up in any other decks. (This was easy to check because I don’t have that many decks–I delete decks at the end of each semester.)

***Here’s what I’ve done to try to get around the problem:

  • I deleted the target deck and tried to import the data into a new target deck with a new deck name. (I tried this three times.)
  • I shut down and rebooted the Anki desktop program.
  • I manually synced the program
  • I read the forum topics that have “file import” in the title, and none of the topics I found provide guidance for my situation.

If anyone has ideas that I have not tried, I would be grateful to hear them!

Maybe try some of the Troubleshooting - Anki Manual steps, including Check Database, and seeing if you’re using a recent version.

Find some unique name or other text fragment in the text file and search for it in the Browse window, to see if it’s anywhere to be found.

The message said that 65 notes were updated, rather than creating new notes. Search in the Browse window for some of the 65 entries you see in the Details listing.

If you click on the magnifying glass next to each detail line, it will search for that note in the browser and should reveal where it’s located.

Thanks for these replies. sprvlcn, I updated Anki, restarted Anki, checked add-ons, and restarted my computer. I also “checked database” and got a message saying “database rebuilt and optimized.” Sadly, the problem remains–when I try to import data, the program indicates that all is going well but no entries appear in the deck.

sprvlcn and dae, I searched for several unique student names that are in in the file that I am trying to import. I see why this was a good idea! Unfortunately, the searches came up empty. This confirms that (for some reason) Anki is saying that the file has been imported but the data is not accessible via the program.

I also tried one more thing: I identified two files that I had previously imported successfully as a deck (and which I deleted several months ago). When I tried to import these files again, I faced the same problem. I get several notifications that make it look like they imported successfully but the target deck is empty, and when I search for unique names, the search comes up empty. This makes me think that the problem is not with the file I am trying to upload because the problem is showing up for data files that previously worked.

If anyone has any other suggestions, I would be grateful.

Did you follow @dae’s suggestion of clicking on the magnifying glass icons after expanding the Details section? What did that show in the Browse window?

Maybe post some screenshots of your process.

1 Like

Thank you, @sprvlcn, for the clarification of @dae’s suggestion. In retrospect, I didn’t completely understand that the magnifying glass was in the Details section. After I click on the magnifying glass, the data then appears in the target deck. I have no idea what I must have been doing to create the error but I am grateful to you both for your guidance.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.