I never see cards from some subdecks, how can I make it so it pulls new cards from all subdecks?

Here’s the background of my problem: I have a deck that has about a dozen subdecks, and some of those have a few subdecks. When I study, what I’d like is to just click on that top-level deck, and have it pull new and review cards from the subdecks in some sort of roughly equal way.

However, currently what I experience is that about 99% of the cards I see when I study the top level deck are from a few larger/older subdecks. There are a bunch of smaller/newer subdecks that I’ve literally never seen a card from. Even factoring in the fact that random draws will tend to be from the larger subdecks, I should see some fraction of these other subdecks, and I don’t see any.

Under the option for the top-level deck, I have “insertion order: random”, which from what I understand, should do what I want. This is the default settings, which are used by all decks/subdecks I have. Under "preferences->scheduling, I don’t have “V3 scheduler” checked, but I get the feeling the problem can be solved another way.

I’ve read stuff involving using a filtered deck, but I read the ankiweb docs section on this and I don’t see how it would solve my problem. Does anyone have any advice? thank you.