How to create leeches?

Hi folks!

I am using Anki Desktop 2.1.43 (German version).

How do I get the leeches to work? I use the standard “easy” type cards. Some of them need rework, so I decided to let Anki automatically suspend these via “leeches”. I did not change the deck settings, so after eight times clicking on “again” the card in question should be suspended. But it doesn’t, the card is still active and never gets automatically suspended.

I even created a separate deck with only one card in it and changed the leech counter to 1, but the card is not suspended, even after 10 times clicking on “again”.

I searched the web and this forum and nobody has asked this question before. So I guess, I’m missing something very obvious.

Please give me a hint, how I could get the leeches to work properly.

Have you setted the option “Suspend Card” in the deck options > lapses? I think, by default is setted to tag only, which btw I find a better option: you can always check the tagged leeches and suspend them manually if you want.

If suspend card is not activated, then you should have a few cards tagged as “leech” in the browser. Otherwise, you may check the leech threshold value.

Another possibility is that you’re clicking “aagain” on new cards, I think Anki won’t detect new cards as leeches in any case.

.

.
When any problem card is displayed in the study screen, you can “suspend” it immediately by pressing Shift+@

The Suspend option is also available by pressing “More” at the lower right of the study screen.

If you click Browse, you can see the newly-suspended card highlighted in yellow in the browser.

Thanks for your reply!

I double checked the suspend cards option, it is set to “suspend”. And for testing purposes I set the counter to 2 and made sure the card was not “new”. No luck so far.

As said, since apparently I’m the only one with this problem, there must be a way to use this feature.

Could at least someone confirm that it actually works with his cards? If so, this would be a strong hint for me, that I am the one who causes this odd behaviour and that it is no program error.

Thank you for your suggestion. Definitely an option I’m going to use if any other solution fails. But to be honest, I’d really like to have this auto-suspension feature to be working, since there might be some other cards hard to learn.

I guess what @cqg meant with “new cards” are learning cards. If you fail a review card, the lapse counter increases by one. But if you immediately fail it again, the counter won’t increase because it’s a relearning card now. Only after finishing the (re)learning steps will lapses be counted again.
So try setting the threshold to 1 and then rate a review card as Again. There should be a message that the card has been suspended.

1 Like

Yes, exactly, sorry for the confusion.

OK, I had a look in the card browser. Some of my cards have a value other than 0 for the “failures” value. So basically, Anki updates the number of bad cards. That’s fine :slight_smile: And it even suspended one card, which is even better.

The only thing I have to figure out now is when exactly the counter is increased. That is still a mystery to me, to be honest.

Anyway, thanks to all of you for your support. I’ll do some further experimental research on this topic, but your input pointed me in the right direction.

Happy learning!

One thing to note is that leeches aren’t suspended retroactively. So if a card has 3 lapses and you reduce the threshold from 5 to 3, it will not suddenly become a leech, but only when the card lapses again.

The only thing I have to figure out now is when exactly the counter is increased. That is still a mystery to me, to be honest.

That’s what I’ve tried to explain in my last post. What’s still unclear?

2 Likes

I think I got it now. Cards that are marked with “again” multiple times in a row don’t increase the counter, they have to advance first.
Thanks!