Hard Button in Learning

I am wondering whether there should or should not be a hard button when learning new cards, because it seems it depends on the device.

I first started wondering about this issue when I was trying to understand these values in the “Answer Buttons” statistics chart (screenshot from Mac version):

Screen Shot 2020-08-15 at 11.49.52

Button 2 should be the hard button, but as far as I can recall, I have never yet used it. Yet according to the graph, I have used it almost as often as the good button.

With a little investigating, I have learned that I have a hard button for cards in the learning phase on the iPhone but not on iPad.



Both of those screenshots should reflect identical starting conditions. I started with all devices in sync. As I had already learned new cards for the day, I chose the Custom Study “Increase today’s new card limit” for the purpose of testing, and then I got the screenshot from the answer portion of the first card. Without answering, I then forced a full sync to download from the web, so as to undo the test.

I believe that is what is causing the imbalanced answer button numbers in the graph. Similarly, below is a card that I most recently studied this morning on iPad and previously last night on iPhone. I answered “Good” each time, but it was given a rating of 2 on my iPad and a 3 on my iPhone, which is consistent with the order the buttons were presented on each device.

Screen Shot 2020-08-15 at 11.47.01

I believe one of these platforms is not behaving correctly. Please note that the iPhone (with the hard button) is an older device maxed out on iOS 12.4.8, while the iPad, being newer, is on iPad OS 13.5.1. Both are using AnkiMobile 20.0.65 (20065.3).

If this is a bug, do you mind telling me which device is behaving correctly, so I can study only with it until the issue is resolved?

That’s strange, it’s as if your iPad thinks you’re on the old scheduler. After ensuring your clients are in sync, please force a full sync in the preferences screen of the iPad, then choose ‘download’ on the sync - does that help?

1 Like

I now have a hard button on my iPad. I have done several full syncs over the course of the past several days, including as part of my test in my original post. I seem to recall running my test a couple times before posting (including a full sync), but I cannot be sure.

I am sorry that so far I cannot provide exact information at finding reproducible steps. This is the end of my first week with Anki, so I have spent a lot of time learning and trying different things, and I cannot remember the sequence of all the things I did.

For now, thanks to your reply, I know that the iPad was the one in error, that I should have a hard button based on my selection of the new scheduler. I have tried to repeat my test, but I each time the hard button is where it is supposed to be. If I see the hard button go missing again, I will try to find some steps and report again.

Is it possible to manually override the record of the past reviews to change those answer ratings from 2 to 3, perhaps via the debug console? Not a big deal, but I like to clean up these kinds of things when I can.

The following in the debug console will change ease 2 to ease 3. You’ll need to do a one way sync afterwards, so please ensure you’re in sync first, and export your collection as a backup first.

mw.col.db.execute("update revlog set ease = 3 where ease = 2")

Thank you again. It appears everything is resolved. With that last little minor point, I now have my study routine configured to my taste and it is functioning very well. I couldn’t be happier with my choice to use Anki.

1 Like

I just had a similar problem after switching to the Anki 2.1 scheduler. On the iOS versions there was no “hard” button when the card was new or in learning.
The button appeared again after deleting and reinstalling the app, syncing, forcing a full resync again and then restarting the app. Maybe this helps someone who has the same problem.

I am using Anki version 2.1.35 and version 2.0.67 for the iOS app. Both should be the latest ones.

Thanks for the report, I’ve made a note to see if I can reproduce this.

Thanks again for the report, a fix for this will be in the next update.

1 Like