Front text of cards disappearing

Hello- I have been having a problem for quite some time and after talking with some knowledgeable users I’m pretty sure I have some kind of bug. Over the last month or two, I’ve noticed that some of my review cards are missing text in the front. On many of them, the front appears blank altogether but when I click “show answer”, the back still shows the answer and other text. When I click edit card, it shows that the front text is still there. But, for some reason, it will not appear while clicking through review cards. From what I can tell, this is happening to random cards in my master deck, in a progressive manner- meaning that more and more cards are losing their text in the front. For example, I frequently come across review cards that I know I were functioning fine last week, but this week they are lacking text in the title. I was told to try updating my Anki to the latest version and I did, but if anything this only made the problem worse. I’ve done about 150 reviews today and I would estimate that about a quarter of them were missing the front text entirely or read, “No cloze 1 found on card. Please either add a cloze deletion, or use the Empty cards tool.” I’ve included some screenshots of exactly what I am seeing. Again, this is happening progressively- more and more cards are being affected and I am 100% sure I am not just seeing the same few dysfunctional cards over and over again. If anyone has any ideas please let me know, thank you!

Please see https://docs.ankiweb.net/#/editing?id=cloze-deletion

The cloze deletion used to be working fine for that card. There used to be an answer there but for some reason it has disappeared… this is happening to more and more cards in my deck as time goes on.

My guess is you’ve installed some add-on that alters the editing behaviour, and it has incorrectly changed your notes.

Please post your installed add-ons (Help - About - Copy Debug Info).

Anki 2.1.33 (3f403040) Python 3.8.0 Qt 5.14.2 PyQt 5.14.2
Platform: Mac 10.15.4
Flags: frz=True ao=True sv=1
Add-ons, last update check: 2020-09-06 18:07:28


===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
Advanced Browser ['874215009', 2020-04-22T17:45, 'None', '']
Batch Editing ['291119185', 2019-06-02T13:47, 'None', '']
BetterSearch ['1052724801', 2020-07-28T17:44, 'None', '']
Edit Field During Review ['1020366288', 2020-01-29T10:33, 'None', '']
Frozen Fields ['516643804', 2020-02-29T22:12, 'None', '']
Hierarchical Tags 2 ['594329229', 2020-04-11T11:36, 'None', '']
Highlight Search Results in the Browser ['225180905', 2018-02-16T18:40, 'None', '']
Hint Hotkeys ['1844908621', 2017-08-29T13:53, 'None', '']
Image Occlusion Enhanced for Anki 21 alpha ['1374772155', 2020-04-27T21:21, 'None', '']
More Decks Stats and Time Left ['1556734708', 2020-03-31T15:19, 'None', '']
Special Fields ['1102281552', 2020-08-16T10:18, 'None', '']
Web Browser - Search terms Import texts and images automatically ['864545277', 2020-08-29T13:23, 'None', '']

===IDs of active AnkiWeb add-ons===
1020366288 1052724801 1102281552 1374772155 1556734708 1844908621 225180905 291119185 516643804 594329229 864545277 874215009

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])

The culprit is found.

To prevent something similar in the future, please uninstall it and install Edit Field During Review (Cloze) if you still want to edit cloze fields during review - https://ankiweb.net/shared/info/385888438

I don’t know how much I can do here and how much information can be restored, but if you could send me your collection (File - Export) and the oldest backup, maybe some information in close fields can be restored, I don’t know.

https://docs.ankiweb.net/#/files?id=file-locations

But since you’re apparently using a pre-made Anki deck, maybe it’s possible to fix all broken cards using the Special Fields add-on, but I’m not familiar with the add-on and need to take a closer look at it to be sure. But if it’s not, it should be still possible to fix them as long as I have the original pre-made Anki deck and your Anki deck.

But this is only about […] in the edit window and “No cloze 1 found on card. Please either add a cloze deletion, or use the Empty cards tool.”

It’s unlikely the add-on is accountable for a blank screen on the cards. And I’m not sure what’s wrong with the second screenshot (with Lecture Notes and a screenshot). It looks good to me but I’m not familiar with the pre-made deck.

In this case, maybe the card template or JavaScript is broken. Maybe one HTML tag was not closed properly. Next time when you see a blank or broken card, if you could open the card browser and export just one card as an .apkg file (Notes - Export Notes), it’d be easier to find where’s the problem and maybe fix it.

Or since it’s a pre-made deck, creating a new profile, importing the pre-made deck and coping the front and back template in a temporary text file, so it can be later copied to your card template, might work too.

3 Likes

Thank you for your help so far- I wanted to provide a quick update. I got in touch with the author of the pre-made deck and I was able to re-download the deck using the special fields add-on, and it fixed almost all of my cards. However, I have a second pre-made deck that is still not working properly (same problem as before- front of cards saying “empty…”). I went to re-download it using special fields, but I could not re-download the deck because I had accidentally changed the note type of all the cards in this deck. Anki wouldn’t let me update the deck because the note type is now different for all of the cards.

So, I made a second Anki profile and downloaded the pre-made deck onto it so I could figure out which note type it uses. It turns out that it uses several different note types, not one. There doesn’t seem to be a pattern as to which cards use which note type, and there are over twenty thousand cards in the deck. Is there any way to revert the cards in this deck to their original note types, without going through the entire deck, card by card?

Is there any way to revert the cards in this deck to their original note types, without going through the entire deck, card by card?

There might be a better way and I haven’t tried it, but I think it should work.

Basically, just move your cards to a temporary note type (its copy), delete the current note type, import an Anki deck with the original note type and move your cards back.

  • Use Anki - Tools - Manage Note Types to create a copy of the current note type.

  • Use the card browser to select all cards with the current note type and then Notes - Change Note Type

  • Use Anki - Tools - Manage Note Types to delete the current note type

  • Use the second profile to create a new card with the original note type and export it as an apkg file. Just one card with the first non-empty field should be enough, I guess, or just fill all fields with their name.

  • Import it in your main Anki profile.

  • Use again Notes - Change Note Type to change back to the original note type.

You’ll need to do it for each note type that had been changed.

Once it’s done, maybe you’ll be able to update your deck using the special fields add-on. It should work but I’m not 100% sure.

1 Like