Flagged cards shown wrongly

I’m using

Anki 2.1.52 (a989e508) Python 3.9.7 Qt 6.3.0 PyQt 6.3.0
Platform: Mac 12.4
Flags: frz=True ao=False sv=3
Add-ons, last update check: 2022-05-27 09:42:14

===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])

===IDs of active AnkiWeb add-ons===

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])

and observed a strangeness. I have a deck like


and it’s definitely empty

also the Rebuild states

But in my decks it shows

It will then show a card which in the past indeed was flagged red, but now it isn’t. Anyhow, even after closing the card comes back in the list.

1 Like

The search is applied when you (re)build the filtered deck, not after every change you make to a card.

1 Like

Well, if I try to rebuild it, there is nothing. Hence the message. But still it shows one card. And that one appeared “by itself” not in the course of rebuilding a deck.

Still, there is something wrong. I have a search for leeches. Once after studying them I go through the list in the Browse and remove the leech tag. Now when I ask to rebuild the deck it tells me that there is no match (which is correct). But: it does not empty the deck. Rather it keeps the old leeches in that list. When I ask to rebuild, then it should do as told and end up with an empty list!

The filtered deck options won’t proceed if your search doesn’t match anything. If you use the rebuild button at the bottom of the main Anki window, it should do what you want.

Well, there is no such button. Only

Ah, well. It’s on the page of the deck itself…

Ok. I pressed the Rebuild but still it does keep the old stuff although I just erased the leech flags from all cards.

Works for me. If I create a filtered deck with a certain flag, change the flag of the existing cards, and rebuild, it empties the deck.

I have

Version ⁨2.1.54 (b6a7760c)⁩
Python 3.9.7 Qt 6.3.1 PyQt 6.3.1

I still cannot reproduce it. If I tag some cards leech, create a filtered deck with tag:leech, remove the tag from the notes, and click rebuild down the bottom, the deck becomes empty for me.

Hmm. Maybe the issue is gone when trying to catch it. But anyhow, is there a way to make a pre/after image so you could find the cause? If so I would try to produce that.

As I thought. Now I ran the steps again and it worked as it should…