Filtered deck on iOS glitch

I made a cram filtered deck based on a flag and I unchecked the “reschedule based on answers” box because I want to review every card before the exam, even if it’s not due.

This works fine on Mac, it gives 4 options with the easy one being “end” which removes the card from the deck. On iOS however, every option is “end”, even the again button. This makes the iOS app completely useless for such a deck and I’m forced to review on my Mac.

Is there any fix for this?

If the filtered deck was created with an older Anki version, you’ll need to either create a new one, or open its settings and adjust the delays for again/hard/good, since they are configured separately now.

I created it on Anki ⁨2.1.66 on Mac and my iOS app is on the latest 23.12.1. I can’t find any options for the settings of filtered decks on the iOS app. Could you please elaborate?

I’m hesitant to update the Mac app as I rely heavily on Cloze Overlapper 2.1 and Mathjax so I’m afraid of breaking changes and I’m currently in the middle of exams.

After exams, you can move away from the extension to add a note type/template
GitHub - michalrus/anki-simple-cloze-overlapper: Simple Cloze Overlapper template for Anki 2.1 (probably any version, as it's JavaScript-only)

Do you use a Mathjax extension? will try to find an alternative/solution

if you don’t use any Mathjax extension, then updating won’t be a problem, changes related in 23.10+

You can access them by tapping on the bottom right cog, then Study Options.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.