Filter on Marked cards not working

Marked cards aren’t working for me in the desktop app.
My search filter is simply “tag:marked”

Nothing shows up in the browser, nor will anything show up in a filtered deck when I hit “rebuild”

Also, the tag “marked” doesn’t show up in the list of saved filters at the bottom on the left pane of the browser either (while other tags do).

Other tags work fine, only “marked” seems to be broken.

As a comparison, my filtered decks and card browser work just fine with marked cards in Ankidroid.

Anki version 2.1.38

Are you sure you “marked” the cards? Maybe you used flags? To show all flagged cards use -flag:0.

yes, as I said, all works fine in Ankdroid.
Also, when I look at a word in the browser, I can see “marked” in the tag field.

That’s very odd. After all, marked is just another tag. Maybe someone else has an idea what could possibly be the issue.
Until then, a few things you can try (for troubleshooting):

  • Check database.
  • Search for tag:*marked*. Does anything show up?
  • Clear unused tags. Does marked appear in the sidebar now?

ok, fixed.

tag:*marked* worked, and so did tag:*marked and tag:marked*

But tag:marked still did not

Then I tried “Clear unused tags” and that fixed it. No problems now, works as expected.


1 Like