Failing to optimize/evaluate FSRS for *some* presets: error 500 only 0 reviews were found

I’m using linux mint. Yesterday the anki flatpak got updated to version 24.04.1 so I tried to optimize the FSRS parameters.
Two out of the four presets I have got this error

Error: 500: Only 0 reviews were found. You must have at least 400 reviews for this operation.

It’s not the first time I optimize/use FSRS. I did it back in January, then read about the bug where the parameters were getting worse so I decided to wait for the next update.
All the presets refer to decks with many reviews, specifically one that coincidentally got the error (the preset for my reviews from tango jlpt N5 to N1).

I tried to fiddle with the “ignore reviews before” feature but got nothing out of it. Of couse the default date 01/01/1970 worked for the other 2 presets. I tried values from /1600 to /2020

How many is “many”? (FSRS only considers 1 review per card per day, so it’s sometimes harder to get to the minimum than you think.) Are all of those cards still unsuspended? Besides changing the date, are you limiting your optimization set in any other ways (in the search box)?

2 Likes

Solved.
With Danika’s input I went back to inspect the line above “ignore reviews before” (the search box, right?). Turns out I had very slightly changed the preset name in these months and anki didn’t update it…

Now that this is done, I’d like to add one little question: in the search box for one of the presets it says

preset:“my preset name” -is:suspended

and this line is not “text” like in the other cases, it’s greyed out and I can’t edit it but simply replace it with my input if I start typing. The optimization went smoothly with this one, so I guess this is more of a curiosity.

The greyed out text is the default value of the field for the preset.

2 Likes