Anki Forums

Enter to search in the Browse screen not working in Japanese?

Hello

From the decision of Anki2.1.44 (PC), the search is a successful phenomenon, but if there is a similar phenomenon phenomenon, is there a solution phenomenon phenomenon?

Even if I search for the word I want to look up in the search form, it is not displayed. I used to be able to do it.

It is a little hard to understand. Can you give an example of a search that is not working correctly?

Thanks for the reply.
Sorry for the lack of clarity.

For example, when I search for the word “carve”, the card doesn’t show up.

This is despite the fact that there are cards in the deck that contain “carve”.But different cards come up. By the way, every time I search for it, this card appears.

I can not reproduce this - when I type in “carve” and press enter, the carve card appears. Maybe you have installed an add-on which is changing things?

1 Like

Thanks for the reply.
I disabled all my add-ons, but it didn’t change.

By the way, I can search on the web and on the iPhone and ipad apps.

Custom Background Image and Gear Icon

Did you restart Anki afterwards?

スクリーンショットを見る限り、たぶん日本語が母語の方だと思いますので日本語で書かせていただきます。

アドオンを無効にしても変化がなかったということですが、どちらの方法を試しましたか?

  1. Ankiの起動時にShiftキーを押す(一時的にアドオンが無効な状態で起動)
  2. アドオンダイアログの「有効無効の切り替え」で全てを無効にした

もし2を行ったのであれば、@Rumo さんが書いてるように、その後にAnkiを再起動しないと設定は反映されませんので、その点を確認してみて下さい。

一応念の為に確認したいのですが、2枚目のスクショで、検索欄にcarveと入力してからEnterを押し、その後に上から下まで全部スクロールしても、1枚目のスクショにあるカードが見当たらないということですか?

ちゃんとアドオンを無効にしてるし、Enterも押してるがそれでも検索が機能しないというのであれば、その該当のカード1枚をエクスポートして、どこか適当なオンラインストレージにアップしてもらえませんか?こちらで検索できるかどうか確認してみたいので。エクスポートの方法は、

  1. 1枚目のスクショの状態で、そのcarveの行の上で右クリック(MacだとたぶんCtrl + クリック)
  2. 「ノートを書き出す」をクリック
  3. 「ファイルの形」はデフォルトのままで、スケジュールとかメディアとかはチェックはずして、「書き出す」を実行

ここの掲示板は.apkgファイルを添付できないみたいなので、その.apkgファイルをオンラインストレージにアップしてそのリンクをここに貼ってもらえれば、ダウンロードして確認してみます。

Thanks.

Yes

返信ありがとうございます。
1.2.どちらとも試みましたが、ダメでした。

すべてスクロールしたらあるかもしれませんが、1万カードあるので探すのは困難です。

carveのカードが見つからなかったので、別のカードとなりますが、anki.pkgを挙げときます。

https://www.datadeliver.net/receiver/file_box.do?fb=5366fb61aa1f4e05a59546944093bea2&rc=cd8ee141c05b452c9b3a851b66fd101f&lang=ja
(パスワード:anki)

よろしくおねがいいたします。

Searching for ‘PBC’ in that example deck works for me too. I’m not sure why it wouldn’t be working for you. Are you pressing the enter key on your keyboard to search? Have you tried pressing it again?

Thanks for the advice every day.

I’m trying to do as you said, but it’s not working.
I’ve recorded a screenshot so you can check it out.

https://www.datadeliver.net/receiver/file_box.do?fb=6e9121c9867b4728b5672954203366d2&rc=dcfbc37bcbc9403fb78af2cbcf804825&lang=ja
(pass:anki)

私もその.apkgファイルを他のカードがたくさんあるプロファイルにインポートしてみて、"胆汁"とか"PBC"とか"肝移植の適応"とかの文字で検索してみましたが、ちゃんとそのカードだけがリストアップされました。

動画(スクリーンキャスト)の方も見ましたが、検索欄に文字を入力後にカチッカチッと音がしてる時にエンターを押してるっていうことですよね?これを見る限り、エンターに全く反応していないようですね。Anki以外のソフトではちゃんとエンターキーは機能してますか?あと、Anki内でそのブラウザの検索欄以外ではエンターキーは機能してますか。例えば、カード学習中に問題側の表示中にエンター押したらちゃんと解答側が表示されますか?ノートを追加するダイアログでCommand + Enter押したらノートが追加されますか?

もし本当に検索の時だけエンターキーが機能しないのなら、正直原因の見当がつきません。少しプログラミングをかじっているので、ソースコードのこの検索機能に該当する部分を軽くチェックしてみたんですが、特にバグの可能性がある部分も無いように見えます。このフォーラムやr/anki(Ankiのユーザーが集まってる非公式のフォーラム)などを結構チェックしてるのですが、一回もこういう報告を見たことがないです。

When problems occur - Frequently Asked Questions
本当はこれを最初に貼るべきだったのですが、Ankiにおける一般的なトラブルシュートの方法が書いてあるので、まだ試していない項目があったらぜひ試してみて下さい。

あと、既に現在の最新版(2.1.44)にされてるみたいですが、古いバージョンや2.1.45のβ版で違いがあるか見てみるのもいいかもしれません。ただし、もし試すならデータのバックアップをちゃんと取って、復元方法も事前に十分に理解してから行って下さい。ベータ版かどうかに関わらず、新しいバージョンを起動した後に古いバージョンを起動する場合はDowngradingを実行してからにしてください。そうしないと古いバージョンで起動できません。

Thanks for all the advice guys, every time.
I downgraded to Ver 2.40 and now I can search.

I’ll use 2.40 for the time being.

Thank you very much for your help this time.

Maybe Japanese translated suggestion “文字を入力し、Enterキー” in search form is wrong. You just enter words and press “Command + Enter”. (MacOS, Anki ver 2.1.44)

検索語を入れたあと、エンターキーではなく、Command + エンター で検索出来ました。
古いバージョンでは横に検索ボタンが表示されていたので、気づきにくかったです。

Hi,

The search function is not working at all on my laptop.
When I try to search by typing the word and tap enter/return button, the search window scrolls down to the very bottom of the current deck and that’s it. All of the cards are shown and no cards were searched.

The search function was working when I first started using Anki, but it has not been working for quite some time now, probably since one of the update?
I ignored the problem up until now, but I would like to get some assistance to resolve it.
My laptop is Macbook Pro Mid 2014, currently using Anki 2.1.44.
I sync my account with my iPad and iPhone. The search function is perfectly fine in these devices.
Restarting of my laptop and reinstallation of the Anki did not resolve the problem. Please help.

Could be caused by an add-on. Try disabling add-ons and see if that fixes the problem. Please see When problems occur - Frequently Asked Questions

Thank you for the reply.
I just tried disabling add-ons, but it did not fix the problem.

In addition, I only use one add-on, and the problem started before installing it, so it should be safe to conclude that the add-on is not the problem.

How about trying “command + Enter” for searching? In my case, I was troubled the same problem.

I’ve merged these threads together because you all appear to be Japanese speakers, so I suspect it may be related to your input method, or Japanese environment.

I can not reproduce this when I set Anki’s interface to Japanese, and use Japanese input on a Mac. For me, hitting enter once to complete the Japanese input, and then again to search, works. I am using macOS 11.4. You all appear to be using 10.16. Perhaps the issue is specific to that macOS version, and updating may help?

1 Like

Thank you all for the great tips.
In my case, “command + enter” for searching resolved the problem!

According to the posts so far, it seems the version 2.1.44 requires “command + enter” to search while the older version just needs “enter” only.

Thank you all!

1 Like