Anki Forums

Deck Update Fails to Import

I’ve been trying to import an update on a shared deck to my profile. The Deck is huge but the new update comes with no media and is less than 10mb. While trying to import the deck, it only displays “processing” as shown on the image below and can remains like that even for hours until I end Anki using my Task Manager.

I’ve tried checking my database and media but the problem persists. I’ve also tried importing the update into a new profile and it worked just fine. This narrowed down the source of the problem to my current collection. Importing all unsuspended cards in my collection and trying to reimport it to a new profile also seems to produce the same problem confirming that the issue is indeed in my collection and not the update.
Doesn’t seem to be an add-on problem also, since disabling all my add-ons still didn’t fix the issue.

Please does anyone have any idea what the issue might be?

Support

If you can reproduce the problem in 2.1.33, could you please share your collection (without media) and the file you’re trying to import privately so I can try to reproduce the problem?

Thanks a lot. I’ve tried sharing them but it seems apkg files aren’t supported for upload.

You’ll need to use a third-party upload site like https://gofile.io/welcome

Done. Thank you.

I imported your collection, then imported the other deck, and it imported in about 7 seconds on this computer. Does it appear to be using CPU when you look in task manager? Have you tried waiting longer? Does your computer have an SSD, or a spinning hard disk?

Mmm. It does appear to use a lot of CPU. I’ve left it running for more than an hour several times only to come back and see the system being laggy/frozen. It does not have SSD or a spinning hard disk. Uses HDD instead.
I’d say it’s a low end PC with it’s kind of specs.

I’m guessing you’re running out of memory and it’s having to use the pagefile. It may eventually complete if given enough time (eg leaving it overnight). I’m afraid the only suggestion I have for you at this point is to import it into a separate profile, export parts of it, and import each in turn.

That’s the exact thing I tried yesterday. And it worked! Thanks a lot for your time. :slight_smile: