Deck from semi colon delimited file sound not working, cards disappear

I’ve made a deck for studying Turkish that is currently in the form of a semicolon delimited file of lines that look like this:
“But let me drink something”;“Ama bir şey içeyim”;[Sound:0003.mp3]
expecting that the sound would play when I click on ‘answer’. It doesn’t despite all the mp3 files having been cut and pasted into the ‘C\Users\User\AppData\Roaming\Anki2\User 1\’ folder.
I haven’t used anki for years, I thought this worked the last time I did this. There are over 800 cards so I don’t want to manually add sound to each one. Dragging one of the mp3s onto mpv.exe in the Anki program files folder plays it. Tools/check media says its all there but none of the files are used.Allowing HTML tags was selected during the import.

  • What is happening instead of what you expect?
  • What do the notes created by your import look like?
  • Is the sound tag capitalized in all of your notes?
  • What do the card templates for your notetype look like?
  • What are your auto-play settings in your Deck Options?
1 Like

Thanks for the reply:-

What is happening instead of what you expect?

The cards function as they should (card appears, click answer, answer in Turkish appears, but no sound.

What do the notes created by your import look like?

Browse: select ‘Notes’ rather than ‘Cards’ shows ‘Sort Field’ as ‘But let me drink something’ etc, and Note type as ‘Basic’ for all cards, and ‘Cards’ as 1.

Clicking 'Fields shows;
1 Front
2 Back
3 sound

Of the 5 option buttons, the only one clicked is ‘Sort by this field in the browser’ when ‘Front’ is selected.

Exporting notes as .txt produces:-

#tags column:4
Would you like to eat something now? Şimdi bir şey yemek ister misiniz? [sound:0000.mp3]

Is the sound tag capitalized in all of your notes?

All as in the original post. Behavior unchanged after changing it to all lower case.

What do the card templates for your notetype look like?

Card type 1:Card !:Front → Back

‘Front Template’ button selected:-

‘Back Template’ button selected:-

What are your auto-play settings in your Deck Options?

'Don’t play automatically ’ is deselected, as is the other option below it.

I do believe that tag needs to be in lowercase to work.

Anki will only show the things from a note that you tell it to add to a card. You need to add the audio field to your template(s). Field Replacements - Anki Manual

I’m sorry, but having looked through that section again, I’m still none the wiser about how to add the audio field to my template. The only thing I’ve found online is at ankiapp(dot)com…do-i-add-audio-to-a-flashcard- (can’t post links here…)
which refers to adding a sound file to each card individually, unless i’m misreading it. I’m not prepared to do that with all 811 cards. I’d prefer to use some other SRS system if thats the only option.How do I add an audio field to my template, so that all the cards formatted as “front text”;“back text”[sound:x.mp3] will play? Sorry if I’m missing the obvious, I just don’t see it at the moment.

I made a new deck with only 3 cards to test, with this format:
“Would you like to eat something now?”;[sound:0000.mp3]
the audio plays as an answer. For some reason there are 2 play buttons visible in the answer field, although only 1 audio file plays.

I think you might be mixed up between what a card is and what a note is. That set of fields you imported is a note. Getting Started - Anki Manual

You’ve already added a sound file to each note individually. That part is done. If you want Anki to show/play that field on your cards, you need to name it on the templates that make those cards – just like you name the “Front” and “Back” fields on the templates now.

For a very basic notetype and card template like yours, if your 3rd field is called sound (capitalization matters here too), you need to add {{sound}} on the template, exactly where you want that play button to appear. That’s what is explained in the “Field Replacements” page I already posted.

I’d have to see that notetype and template to help you troubleshoot that one, but once you understand the above, hopefully you won’t need that.

I’ve deleted all anki files, folders, etc from my pc, and loaded up anki 2.1.49 from an old usb stick. I’ve made a deck with this format of file:
Everything done as before, fully expecting the same non working result…and it works perfectly.
Why wouldn’t it do that for new anki? No idea. I’m tempted to stick with the old one, apart from the fact that I’m maybe missing out on more functinality. But the old one works…
Thanks Danika, your help is appreciated!

2.1.49 works the same as the current version in all of these respects.

I interpreted that as a missing-semi-colon-typo above, but – do you have "back" and [sound0001.mp3] just like that, together in the same field of your note? Then you’ll be able to call them with a single field replacement on your template – whatever the name of that field is. [Although, I’d discourage you from having media and text in the same field, because it limits how you can use the fields to make other types of cards you may want in the future.]

Again – what your cards look like is determined by what fields your notetype has, and what fields you name in your templates. It might help make that clearer for you if you renamed your fields to what they really are – like, EnglishSentence, TurkishSentence, TurkishAudio. If you have 3 fields, but only name 2 on your template, then you’ll only have information from those 2 fields on your card.

Yes, there is only 1 semi colon. “back”[sound0001.mp3] is how I made all the cards in this case.

I think the problem may really be that I’ve tried to do what I did 10 years ago with Anki, instead of starting from scratch and reading before I started making anything.

I’m still baffled by the difference between cards, notes, and templates, but to honest I’ll probably only use anki for the first 1500 words or so, as I’m trying to learn mostly using chat gpt for simulated roll play/conversations etc. If I can cope with it’s terrible accent that is! So I’ll come back to this thread if I feel a need to know a better way to do it, but stick with ancient Anki for now.

Thanks again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.