Day boundary and step interval workaround

For some people, with non-standard sleep patterns, the way Anki schedules cards causes issues. If a card is scheduled for the next day, but the current time is one minute before the next day start, instead of getting a one day interval and a sleep period in between, you get the card again one minute later. Ouch!

I’ve found plenty of discussion of the problem online, but no fixes or workarounds. Then I had a lightbulb moment and did this:

  1. Created this filtered deck:
    Name: Due Answered Yesterday
    Search: -rated:1 rated:2 is:due
    Limit to: 9999
  2. When the day boundary is crossed, I populate the deck so these cards will not appear when studying other deck.
  3. At a time of my choosing, likely after I’ve slept, I empty the deck so that the cards become available for studying again.

For me at least, this makes the whole thing Not A Problem™. I hope it helps someone else.

1 Like

Why not simply set Next day starts at option to a more suitable hour?

Because it changes. It does for many people, for instance people that work different shifts on different days.