Dark mode not the same as night mode

It’s hard to label this question, because it has to do with both; ankimobile & ankidesktop.
For reference; I’m using ankimobile on my iPad/iPhone and my linux desktop. I use LaTeX for my cards, as I’m studying mathematics. I’m currently encountering a problem.

Dark mode is NOT the same as night mode? This is very frustrating, and I’m unsure if I’m getting it right. It conflicts with my ability to change the ‘styling’ of my ‘card-templates’ as my iPad is displaying different colors than my computer. It interprets the text-color of my LaTeX-text differently, and they display different card-templates (using the same html-code).

I’m unsure if there’s a fix for this (if there’s an add-on or similiar). I use LaTex a lot, so it would be nice, if I had an accurate representation of what the card looks like on my iPad. I welcome all solutions/ideas

The names are used interchangeably. The desktop and mobile clients have a different shade of black by default, but you can customize this in your card templates with .night_mode.card { background-color: … }. Both desktop and mobile client should be automatically inverting black text to white when night mode is on - is that not happening for you?

First of all, you can customize your Anki interface on your iPad to look different from the PC and both should be functioning well separately from each other. So if you have a Night mode selected on your iPad but Day mode on your PC, it should stay the same after you Synchronize and re-open your Anki app. And no, Night mode is not different from Dark mode, which means, if you have selected an option “Follow system” in you Anki app and let’s say your iPad/PC system is programmed to turn on Dark mode at 6PM then your Anki will automatically appear in a Night mode for you! Hope it makes sense!

Another thing, once you choose in Preferences (Theme) on your iPad to have a forced Night mode, the cards or text should automatically appear as white on black. If you have an issue with it (eg. text is not shown), then try fixing it in Card Templates, and make sure it is specified what you need, eg.

.card.nightMode { font-family: Arial;
font-size: 30px;
text-align: center;
color: white;
background-color: black;

In your specific case, check your CSS Styling (make sure the text color - white, background - black), and maybe have a forced Night Mode on in both PC and iPad, see if it helps.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.