Custom text colors are darker on iPad light mode

When in dark mode, painting the text creates the proper colors, but in light mode it both shows (in the tooltip) and paints a darker color which is harder to read when reviewing the cards. This issue does not happen on my iPhone.

ex. for blue it paints #0040dd instead of #409cff.

I’m on the latest version (2.0.67) and this has been happening for at least a few months (not sure if longer since I’ve only recently been making cards on my iPad).

AnkiMobile uses the standard iOS colours, which change depending on whether you are in light mode or dark mode. In light mode the darker colour is used, as it provides more contrast against a light background.

It’s not just that because it mixes the colors between the two modes. If I set the color in light mode, the darker colors persist on the cards when i switch to dark mode, and vice versa. It embeds a different HTML color in the card depending which mode you make the card on and each color doesn’t adjust when you switch to dark/light mode:

Viewing the card in dark mode doesn’t appear to change anything:

I tried to reproduce the glitch on a family member’s iPad (2018 10.5 iPad Pro) and iPhone 6S and wasn’t able to do so. The iPad I have the glitch on is a 9.7in iPad Pro from 2016. I’ve tried reinstalling the app, but the issue is still there.

I’ve noticed that the color of the icons on the top bar (for card editing) on my iPad are a darker shade of blue when in light mode compared to the other devices (posted below). Maybe this is related?

EDIT: The issue only happens when “Increase Contrast” is turned on in system accessibility settings. If I enable it on my iPhone, the paint color options darken there as well.

Ah, that would explain it - iOS will be altering the system colours when you use that setting.

Ideally Anki would apply a colour class and resolve the particular colours at display time instead of editing time - something to think about for a future update.

That makes sense, since the colors would be the same when that setting’s off, thank you for looking into it.