Cards gone after updating and downgrading

Hi, after i updated to anki 2.29 , when I select browse, no cards show up. I downgraded back to 2.1.15, and there are still no cards.

Molt likely the 2.1.15 and 2.1.29 are using different folder locations. From the manual:

On Windows , the latest Anki versions store your Anki files in your appdata folder. You can access it by opening the file manager, and typing %APPDATA%\Anki2 in the location field. Older versions of Anki stored your Anki files in a folder called Anki in your Documents folder.

On Mac computers, recent Anki versions store all their files in the ~/Library/Application Support/Anki2 folder. The Library folder is hidden by default, but can be revealed in Finder by holding down the option key while clicking on the Go menu. If you’re on an older Anki version, your Anki files will be in your Documents/Anki folder.

On Linux , recent Anki versions store your data in ~/.local/share/Anki2 , or $XDG_DATA_HOME/Anki2 if you have set a custom data path. Older versions of Anki stored your files in ~/Documents/Anki or ~/Anki .

1 Like

All 2.1.x versions should be using the same location. Have you tried restoring from backup? Please do so, update to 2.1.29, and see if the same problem happens again. If it does, please let me know any error messages you got, and send me a backup privately so I can investigate the issue.

Hi thank you all for your input. I ended up restarting my laptop, and somehow everything fixed itself. Im not sure what happened to fix it, but I am still using the 2.1.15 version. I will likely stick with it since I am using some add-ons that are not supported with the 2.1.29 version. ty!

Ok, then in this context older refers to 2.0.x ?

It refers to older 2.0.x releases - later 2.0.x use the same location as 2.1.