Card template refuses to save despite preview looking good

So I came back to Anki after much time away. I did some reviews on my tablet and suddenly one card type was broken, giving me a message saying something on the back couldn’t be displayed. After getting a new install of Anki fixed up on my new laptop, I looked at the card, and sure enough, there was a space in a statement referencing a field. Deleting the space suddenly made the preview show up again, and everything looked perfect. But when trying to save, Anki simply tells me “Card template 1 in notetype [whatever] has a problem. See the preview for more information.” But of course the preview doesn’t have any new information, because it looks just fine. I’ve tried deleting the reference to that field outright, tried deleting all kinds of other stuff, changing formats, etc., but Anki flatly refuses to save the card.

I’ll include the actual code here in case there’s something someone notices. I didn’t create the deck, and it worked fine for years on previous versions of Anki. “{{furigana: Context_jp}}” was the original problem, as it didn’t like having a space there, and simply removing the space makes the preview show up correctly.

<div style="font-size: small;">{{Deck}} - {{Card}}</div>
{{Vocab}} - {{Audio}}

<hr id=answer>

<div class="wkbackside">
{{Reading}} - {{Vocab_Meaning}}

{{#Speech_Type}}<span class="text"><u><b>Type:</b></u> {{Speech_Type}}</span><br>{{/Speech_Type}}

{{#Meaning_Exp}}<u><span class="text"><b>Meaning Explanation</b></span></u><br><span class="text"> {{Meaning_Exp}}</span>

{{#Context_jp}}<u><span class="text"><b>Context Example</b></span></u><br><span class="text">
{{furigana:Context_jp}}{{Context_jp}}</span><span class="text">({{Context_en}})</span>{{/Context_jp}}

Any help greatly appreciated!

1 Like

Can you share a sample deck with a card showing the issue? You can use a website like to upload the deck.

Well, I uploaded a one-card sample deck and then the post got removed for spam, so … I guess link sharing is not okay. I got the same error when exporting the one-note deck, though it does at least seem to have saved it.

New users in the forums can’t post links. You can work around that by pasting the link in parts like gofile d/ foobar or you can just paste the link ID that is shown after /d/.

@dae by the way, can link sharing for new users be made less strict? Maybe new users that opened at least one topic (as opposed to just commenting) can be allowed to share links?

1 Like

Thanks! ID is: 4Nn5jw

The apkg file is coming out completely empty.

Hmm. Maybe it’s not actually saving anything given the error message. I get the same error message trying to export that single deck with 1 note that I get when trying to save changes to the card template. Might just be going through the motions but not actually saving anything. Sigh.

You’ll need to change {{furigana: Context_jp}} to {{furigana:Context_jp}} in the back template. The same issue exists in the second template as well (dropdown at the top).

1 Like

You have publicly revealed my stupidity, thank you, haha. Trying to troubleshoot things while being really sick is apparently not a great idea. I’d just failed to do it in the second template …