Anki error message for cards using a downloaded deck

Back template has a problem:
Found ‘⁨{{Kanji}}⁩’, but there is no field called ‘⁨Kanji⁩’

When I add a Field called “Kanji” It says

“Card template ⁨1⁩ in notetype ‘⁨Kana2.6⁩’ has a problem.
See the preview for more information.”

Not sure what to do. Can anyone help? I’m using the deck called G-Anki

Screenshot and post here

Add Back, Front and Appearance screenshots too


Is this what you wanted to see? tell me if you need more. I really appreciate you trying to help.

Whenever you find a problem with a particular deck, rather than try to fix it yourself, it’s often best to check with the Deck author. But it’s pretty concerning if this person created a template that refers to fields the note doesn’t have, so maybe that would be a dead end. [Right away I notice that the back template (which is apparently the one with the problem, but you didn’t post it) for this card is perhaps made up of the Kanji field repeated 6+ times … which seems unusual. :person_shrugging:t4: ]

A quick Google (g-anki “back template has a problem”) suggests that this deck causes this issue for folks regularly. Give these things a try next –

1 Like

In your Fields tab, second image, try creating a Kanji field

the Reddit link from Danika has comments from users that managed to fix it

1 Like

I tried doing the suggestion of Renaming “Kana Reading” to “Reading” seemed to fix it" Initially as you can see from the screenshots I have no kana reading unless I make it

Then I tried
“Go to manage Note type. Select Kana 2.6 (403 notes), click Fields… Select the first field and rename it Kanji. Click add and name the field “Kana Reading”. Save.”

I still get the same error that the card template 1 in notetype doesnt work, the second suggestion gives me 2 errors rather than one

I replied to Danika, I tried their suggestions in the message below from the reddit but it doesnt seem to work still

Take another look at the post – you might have done those steps out of order.

Their goal was to make sure your note type has every field that is referred to in your template, so you don’t have to change the template. I don’t know what all your template says, but you can search them yourself using the search box above the template.

Searching for {{ will show you each place a field is referenced, so you can figure out which fields you need to add (and they are case-sensitive).

I’m honestly still confused on how you would add it, I don’t see anything like that when I look at the back template. I don’t have anything that is titled Kana or Kana reading on the back template that I can tell. Is there anyway you can help me on discord or something? Sorry if I’m being annoying I’m just not good at this stuff. Or if you’re not comfortable with that if you could keep giving me ideas what to try, because I’m not seeing that { { when I search it

I don’t think splitting the conversation between here and Discord will help anything.

If you put a space between the braces, that won’t work. It’s the same double-curly-braces that start every Field Replacement.

If you want someone else to look through the template for you, post the text of it here – the back template, since that’s what is causing the error.

To post it as a multi-line code-block, 
so that the text is easier to work with. 

Select this feature in the menu, and then paste the text into it –

If you’ve been editing things in the template that haven’t worked, hopefully you’ve been undoing them afterwards. If you haven’t, you should undo them before posting the template here.

Another very realistic option is that you need to start over – and download the deck without all these errors from a better source.

type or paste code here
<font size="4"><a  id="button_1" href = '{{Kanji}}'>Jisho</a> </font>
<font size="4"><a   id="button_1" href="{{Kanji}}">Weblio</a></font>
<font size="4"><a   id="button_1" href="{{Kanji}}&ref=sa">ALC</a></font>
<font size="4"><a   id="button_1" href="{{Kanji}}/m0u/">goo</a></font>
<font size="4"><a   id="button_1" href="{{Kanji}}">Tangorin</a></font>
<font size="3"><a  id="button_1"  href="{{Kanji}}">Weblio Examples</a></font>
<font size="3"><a   id="button_1" href="{{Kanji}}">Tangorin Examples</a></font><br/>
<p class="english2">{{English}}</p>
<p id="altmean" class="alt-english2">{{Alternative Meanings}}</p>
<p class="furigana">{{furigana:Reading}}</p>
<p class="alt-english2">{{furigana:Alternative Reading}}</p>

<div id="container">

{{furigana:Context Sentence 1}}
{{English Sentence 1}}

{{furigana:Context Sentence 2}}

{{English Sentence 2}}


<div id="correctAnswer" style="display:none">{{English}}</div>
//Script for modifying 'Show Answer' behavior for Input types.
var htmlTextNodes = [];
var innerHTMLText = [];
var htmlNodeLength =document.getElementById('typeans').childNodes.length;
var typedAnswer;
var correctAnswer;
var firstBr = null;
var secondBr;

//capture each node to array
for (i = 0; i < htmlNodeLength; i++) {
 htmlTextNodes[i] = document.getElementById('typeans').childNodes[i];
 innerHTMLText[i] = document.getElementById('typeans').childNodes[i].innerHTML;
 //locate <br> tags for output change markers
 if (document.getElementById('typeans').childNodes[i].nodeName == "BR") {
  console.log("Runs if BR");
  if (firstBr != null) {
   secondBr = i;
  } else {
   firstBr = i;

//If answer is correct, firstBr will still be null, so must set to length of typeans.childNode
if (firstBr == null) {
 firstBr = htmlNodeLength;

//assemble typed and correct answer strings
str2 = innerHTMLText.slice(0,firstBr).join("");
var typeParse = str2.replace(/[(/\W, " ")]/g,' ');
var typedAnswer = typeParse.replace(/\s/g, '');
var typedAnsDis = str2.replace(/[^a-zA-Z0-9]/g,' ');
var typedUpper = typedAnswer.toUpperCase();

//typedUpper = "KITTEN"

var corr = document.getElementById('correctAnswer');
str = corr.innerHTML;
var correctParse = str.replace(/[/\W, " "]/g,' ');
var correctAnswer = correctParse.replace(/\s/g, '');

//split alternative answers into array

var getalt = document.getElementById('altmean');
var altmean = getalt.innerHTML;

altmean += ", "
altmean += correctAnswer;

var array = altmean.split(", ");

for ( var i = 0; i < array.length; i++ ) {
    array[i] = "" + array[i].toUpperCase() + "";
    array[i] = "" + array[i].replace(/[/\W, " "]/g,' ');; + "";
    array[i] = "" + array[i].replace(/\s/g, ''); + "";

//Modify answer output
if ((array.indexOf(typedUpper) > -1) &&  (!(typedUpper == "" ))) {
 var c = "<div class=\"animated zoomIn\" id='correct'>"+typedAnsDis+"</div>";
 var d = document.getElementById('typeans');
 d.innerHTML =  c;
} else {
if(typedAnsDis == "") {
typedAnsDis = ":chicken: :chicken: :chicken:";
 var e = "<div class=\"animated \" id='incorrect'>"+typedAnsDis+"</div>";
 var f = document.getElementById('typeans');
 f.innerHTML =  e;

This is what i copied from the back template

Okay. The fields referenced in that tempate are:
{{Alternative Meanings}}
{{furigana:Alternative Reading}}
{{furigana:Context Sentence 1}}
{{English Sentence 1}}
{{furigana:Context Sentence 2}}
{{English Sentence 2}}

Does your note type have all of those? [You can ignore the furigana: , but the rest of the text inside the curly braces needs to match the field name exactly.]
Which one is mentioned in the error you’re currently seeing?

The error just says

“card template 1 in notetype ‘kana2.6’ has a problem. see the preview for more information.”


these are the fields i have

Okay, so … what is the error in the preview (that refers to a specific field)?

I’m going to ask you to put in at least as much effort as I am, so the question for you is – what fields are used in the template that you don’t have in your note type?

[And seriously, the other way to deal with this is to just get a better deck. I don’t know what folks are thinking sometimes, publishing decks with these sorts of errors.]

I don’t understand this type of stuff. I don’t know what specific field it refers to, it doesn’t tell me. My only guess would be this Kanji field, but I don’t even see that in my fields. When I add it, it doesn’t do anything.

Back template has a problem:
Found ‘⁨{{Kanji}}⁩’, but there is no field called ‘⁨Kanji⁩’

“what fields are used in the template that you don’t have in your note type?” I don’t know how to tell. This is my note type

I really like this one because it looks like wanikani and I couldn’t find any others.

^^^This right here is the error in the preview that refers to a specific field.

Nonsense. All you need to do is compare the list that I made for you off all the fields used in the template, to the list you posted of all the fields on your note type. If the template is asking for fields that don’t exist – you’ll keep getting that error – so make a list of those.

For each of those fields, you have to choose – whether you want to remove the reference to the {{field}} in your template, or whether you want to add the field to your note type.

I think I understand what you are saying.

I go to my fields, add the field called kanji, then go into my note types and add it as well then save.

Correct me if this is wrong, but If I am understanding it correctly when I try to add the fields it gives me an error and the only way to exit the menu is by discarding the new changes (aka the new added kanji field type).

Yep, that should do it. Spelling and upper/lower-case matters. Directions – Adding/Editing - Anki Manual . After you add the name, then click save.

No, there isn’t a 2nd step. What you just did ^^^ already added that field to the note type.

I’ve try doing that and before I can save the field of the kanji field I just created I get the error

“Card template ⁨1⁩ in notetype ‘⁨Kana2.6⁩’ has a problem.

the only option is “ok” and “help.” If I click “ok” it takes me back to my fields where I can only exit without saving the new added field called “kanji”